Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mrlockard
Level 7

Not getting activation email

I'm trying to setup a roku express and no matter what I do I'm not getting the activation email. I've checked spam and I've been trying on and off for an hour I don't know what to do at this point.

0 Kudos
101 REPLIES 101\
RokuMary-F
Roku Employee
Roku Employee

Re: Not getting activation email

Hi @mrlockard,

Thanks for letting us know about the issue that you are experiencing.

We would recommend trying to perform a factory reset on your device and setting it back up again to activate the device.
For more information about how to perform a factory reset, visit our Support page here: How do I factory reset my Roku® streaming device?

We would also recommend taking a look at our Support page for more information: How do I resolve an issue when activating or ... - Roku

If you are unable to resolve the issue, please send me a private message with your Roku account email address, and include the serial number/device id of the Roku device along with a summary of the issue you are experiencing. I'll be able to assist you further from there.

Thanks,

Mary

0 Kudos
jgdixon
Level 7

Re: Not getting activation email

Hi Mary,

 

I am having the same problem as this user and the many others on another Community support page you interact with.  How do I send you a PM to pass along the requested information and get a support ticket?

I have already tried all of the suggested troubleshooting methods including the reset.

Thank you 

James

0 Kudos
RokuKariza-D
Roku Employee
Roku Employee

Re: Not getting activation email

Hey @jgdixon

Thanks for letting us know all that you've done.

For further help, please reply here with the serial number of your Roku device. It can be located at the back or underneath the player itself.

All the best,
Kariza

 

Kariza D.
Roku Forum Moderator
0 Kudos
jgdixon
Level 7

Re: Not getting activation email

Come to find out my activation emails were going to my Yahoo trash.  Not exactly sure why.  So for those that are looking for the email, check Inbox, Spam, and Trash I guess.

 

Activated and working now.

0 Kudos
QcoyaaMyk
Level 7

Email Activation

I haven’t received an email activation yet for my tcl roku app

RokuKariza-D
Roku Employee
Roku Employee

Re: EmailFor

Hi @QcoyaaMyk

Thanks for reaching out here in the Community!

If your email address was entered correctly and you still do not see an activation email in your inbox, try the following:

  • Wait a bit longer: In some cases, it may take several minutes to receive the activation email. Be sure you wait a few minutes before troubleshooting.
  • Check your spam folder: Your internet service provider (ISP) or email client (e.g., Gmail, Outlook, etc.) may block emails from unrecognized senders, placing these messages in a spam (or junk) folder. You may need to go into your spam folder and accept Roku as a recognized sender to get the activation email to appear in your inbox.

If the issue persists, we would recommend performing a factory reset on your Roku device then see if that will make a difference. Visit this Support article for instructions on how to factory reset: How do I factory reset my Roku® streaming device?

Let us know how it goes.

All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
Davidquigley
Level 7

Re: EmailFor

Hi I have triple checked my email which is ok, I have checked my inbox, junk, trash in my emails but not received an email for 20 mins. I have also factory reset my Roku box and tried again with no luck. 

0 Kudos
TuptonTrev
Level 7

Re: EmailFor

Getting exactly the same.  Factory reset device as youtube app kept failing even though reloaded.  Now have no working device. Great!

0 Kudos
Charlotte3
Level 7

Re: Not getting activation email

Same happening for me, how do I get this resolved please? Thanks 

0 Kudos