Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

New Roku Ultra remote won't control Sony OLED

Just purchased a Roku Ultra - 2022 version to replace a previous Roku 2020 version. For whatever reason the new device won't configure to control a Sony OLED (2020 model). the device attempts to configure, but the music never turns off and the Ultra never tries any other codes but 1. Simply indicates it can't control the TV. Connected via HDMI. 

the previous Roku worked just fine. 



0 Kudos
Reel Rookie

HDMI-CEC power & volume control not working with Sony XBR-43X800E Bravia Sync

Is there any way to have Roku control the volume of my XBR-43X800E using CEC??

I have enabled Bravia Sync on my Sony XBR-43X800E TV for the (brand new) 2022 Roku Ultra (4802R) and the Roku appears on the Bravia Sync devices list. Going through the Roku remote setup, it recognizes the SONY brand but reminds me to point the remote at the TV and completes the IR remote setup. It suggests that to setup HDMI-CEC I go to the cec-help webpage where I find the instructions to enable Sony Bravia Sync, which are the exact same steps I had previously accomplished. It appears the Roku never even attempts volume control via CEC. (I have retried after a factory rest on the TV and also with an alternate HDMI cable.)

I have, at the same time, been successful in accomplishing CEC power/volume control of two Sony XBR-55X900E TVs with identical Roku units, so I expected this to be equally easy. IR control doesn't suit my system layout or desires. I do hope to make this work!

Tags (1)
0 Kudos
Reel Rookie

Re: New Roku Ultra remote won't control Sony OLED

Same problem here.  It's been working great until just yesterday, now it won't turn off my Sony TV and I've lost volume control.  I've reset the remote and factory reset the Roku.  I guess I'm gonna have to box this thing up.  

0 Kudos
Roku Guru

Re: New Roku Ultra remote won't control Sony OLED

Hi @joejoeU @readingcop @Fergazoid 

Thanks for posting here in the Community.

Perhaps @Tivoburkee can provide some insight as he's our resident remote Community expert.

Moreover, please provide us with the following information for further investigation:

  1. Roku device model, Serial number, Device ID, Software OS/version (these can all be found in Settings > System > About)
  2. Does this issue occur on a specific channel? If so, what channel and what version/build is the channel (this can be found by selecting the channel on the Home screen and pressing the * button)
  3. Tracker ID when this issue occurs (when you see this issue occur, press the Home button 5 times, followed by the Back button 5 times, and provide us with this ID)
  4. Steps to reproduce the issue you are seeing
  5. TV make & model
  6. When the issue started

With this information, we will be able to assist you further.

All the best,

Kariza D.
Roku Forum Moderator
0 Kudos
Community Streaming Expert

Re: New Roku Ultra remote won't control Sony OLED

I would try re-programmable it for the Sony but skip the first positive result by clicking NO even if the sound muted and see if subsequent codes work better. 

If that doesn't work, try searching Sceptre or Westinghouse tv codes? Two known brands that at one time used the Sony code set. 

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
Reel Rookie

Re: New Roku Ultra remote won't control Sony OLED

I identified the issue. I upgraded to the latest Roku Ultra as part of larger upgrade that included replacing my Bang and Olufsen sound bar with a Sonos. The culprit was the Sony was not turning off the music on the B&G soundbar. First time on the Sonos and it worked perfectly. 

Reel Rookie

Re: New Roku Ultra remote won't control Sony OLED

Model: 4802X - Roku Ultra (brand new, new/first installation)

Serial Number: X010008SN5CW

Device ID: S0DA223SN5CW

Software Version: 11.5.0 build 4235-C2

Problem is not channel related.

The problem is that the remote can only be setup for IR functionality, NOT the HDMI-CEC (Sony Bravia Sync). So I don't believe any Tracker ID would be relevant.

The steps, as stated in my OP, are simply that of remote setup. I've tried saying "No" to either the music playing or muted steps, but these always require pointing the remote at the TV and there's never a further step for attempts at HDMI control.

TV: Sony Bravia XBR-43X800E (factory reset, software updated and current and the setup steps on the cec-help webpage were followed). I was recently successful at setting up two XBR-55X900E TVs with identical Roku units.

The issue started with initial setup. I was expecting HDMI-CEC control to work as well as it did on the other two TVs.

0 Kudos
Reel Rookie

Re: New Roku Ultra remote won't control Sony OLED

If I try 'No' at either step in remote setup, it fails without any further attempts being offered.

0 Kudos
Retired Moderator

Re: New Roku Ultra remote won't control Sony OLED


Thanks for the post and providing us with your device information.

I have passed along your concerns and details to the appropriate Roku team to investigate further. 

Once more information is available, I'll be sure to update this Community thread.


Danny R.
Roku Community Moderator
0 Kudos
Channel Surfer

Voice remote Pro no longer controls TV powser/volume/mute after OS 11.5

I bought a new Ultra 4802x in early October.  I paired it with my Sharp TV and was able to control power on/off, and volume (up/down/mute).

Like other owners, the Roku remote lost all those capabilities after the update to OS 11.5 in November.

I checked the TV settings and they shoe no change to the HDMI-CEC settings (and I see the Roku box in the list of detected devices).

I tried the pairing steps and they didn't work; I even tried 'lying' about the music stopping but that didn't work either.

Is there a way to rollback the OS update?  Is Roku technical team working on a solution to this apparently widespread bug?