Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
keap
Reel Rookie

How do I turn off the caption displaying of on-screen text

So on several streaming services including Disney + and Netflix for the last couple days, I’ve had the services displaying on screen text as a caption. So if there is a building with a sign like Community Center, I’ll get a caption at the bottom of the screen that reads Community Center. Same language, no translation, and no captioning of spoken word or credits. I checked the caption settings in Roku Settings and it’s turned off. I don’t know what to do and would rather not have to restore system settings and lose all my channels and logins. This is happening on multiple devices. 

3 REPLIES 3
RokuCarly
Community Moderator
Community Moderator

Re: How do I turn off the caption displaying of on-screen text

A warm welcome here at the Roku Community, @keap!

Thanks for reaching out. No worries! We're here to further assist you with this.

Whenever you are in the specific app you want to disable the screen captioning from, kindly press the star* button on your remote, and a pop-up menu will prompt at the side of your TV. You will have the option for closed-captioning and kindly choose to turn it off. If it is to no avail, we highly suggest contacting customer support of the said apps/channels for further advice. Please be aware that many channels/apps on Roku are created, maintained, and updated by the channel providers themselves. 

Hope this helps!

Kind regards,
Carly

Carly Y.
Roku Community Moderator
0 Kudos
keap
Reel Rookie

Re: How do I turn off the caption displaying of on-screen text

It is off on all of them as well as in the main Roku settings. 

0 Kudos
RokuTakashi
Community Moderator
Community Moderator

Re: How do I turn off the caption displaying of on-screen text

Thanks for keeping us posted, @keap 

We recommend giving a system restart a try to see if you notice any improvements regarding the issue. To do this, navigate to Settings > System > Power (skip if not sub-menu) > System Restart. 

Let us know how this works.

All the best,
Kash

Takashi O.
Roku Community Moderator
0 Kudos