Remotes

Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
nymbis
Reel Rookie

LG tv wont switch source to Roku

Jump to solution

I've setup my Roku remote with my LG tv and it will power on the TV and do most functions but pressing the Roku home button doesn't switch the source on the LG tv.  On my Samsung TVs the Roku home button will switch the TV from it's default channels/home page to the Roku device's source and it's home screen.  I don't know how to get the same functionality on the LG tv as the Samsung has with the Roku remote.

2 Solutions

Accepted Solutions
AvsGunnar
Community Streaming Expert

Re: LG tv wont switch source to Roku

Jump to solution

@nymbis 

Verify that the LG TV has its HDMI CEC (named SimpLink for LG) enabled in its Settings. (use your TV remote, not the Roku remote, to go into the LG settings to enable this.)

Then go to your Roku device and Enable 1-touch play under Settings/System/Control other Devices/1-Touch Play/[checkmark to Enable]

----

Once both the above are enabled, you should be able to press any button on your Roku remote (excluding the Power, Volume, Mute) in order to automatically and simultaneously wake the Roku device, turn your TV on, and switch to the appropriate HDMI input.

LG CEC settings locations- https://www.lg.com/us/support/help-library/lg-tv-how-to-enable-hdmi-cec-CT10000018-20153164607551

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

View solution in original post

najak3d
Newbie

Re: LG tv wont switch source to Roku

Jump to solution

THANK YOU!!!  This fixed a major headache for us -- which was that "every time we turned off our TV, and then back on again later, the LG TV would REVERT back to the WebOS home screen!"

This would force us to pull out the TV Magic Remote, to reselect the ROKU!! (when we ALWAYS want it to be the ROKU, with few exceptions)

So the:
Settings => All Settings => General => System => Additional Settings => Home Settings => [TURN OFF ALL CHECKBOXES]

Fixed this for us!   Now when we turn off the TV (using ROKU remote), it KEEPS the ROKU as Input! (and even preserves the show/channel we were watching!).

So nice!  THank you for sharing this.

View solution in original post

0 Kudos
8 REPLIES 8
AvsGunnar
Community Streaming Expert

Re: LG tv wont switch source to Roku

Jump to solution

@nymbis 

Verify that the LG TV has its HDMI CEC (named SimpLink for LG) enabled in its Settings. (use your TV remote, not the Roku remote, to go into the LG settings to enable this.)

Then go to your Roku device and Enable 1-touch play under Settings/System/Control other Devices/1-Touch Play/[checkmark to Enable]

----

Once both the above are enabled, you should be able to press any button on your Roku remote (excluding the Power, Volume, Mute) in order to automatically and simultaneously wake the Roku device, turn your TV on, and switch to the appropriate HDMI input.

LG CEC settings locations- https://www.lg.com/us/support/help-library/lg-tv-how-to-enable-hdmi-cec-CT10000018-20153164607551

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

nymbis
Reel Rookie

Re: LG tv wont switch source to Roku

Jump to solution

Thanks for the advice.  I had both of those options on and it would work if I changed the source intially and then turned the tv off and back on within a 5-10min window but after a longer period of time it would again load to the LG home screen and not go to the Roku home screen. 
There was an option in the LG settings that would auto load to the LG home screen.  Once I turned that off I'm now able to always load to the Roku home screen.  

Anyhow, hope this can help someone else in a similar situation.

 

Thanks.

wingbike
Newbie

Re: LG tv wont switch source to Roku

Jump to solution

SS+ Roku fix for LG TV's not switching the LG HDMI input when Roku buttons are depressed.
The below fix will permanently fix the above problem. However, you will still have to use the SS+ remote to control Roku.
I had the same problem with my new 2023 LGOLED65C3 TV. Make sure the LG is set correctly for HDMI-CEC (simplink) and the SS+ remote is set correctly for 1-touch play, which it probably already is by default.
An HDMI splitter is needed (not HDMI switch). Plug the SS+ into the splitter input and connect an HDMI UHD HDMI cable between the 1st splitter output (2nd output not used) and the LGTV HDMI input. Connect the included power supply and leave it plugged in.
Thats it! I used the OREI UHDS-102 splitter, 25$ on Amazon. I chose it because it supports 4k@60Hz and its HDCP 2.2 compliant. You may need to purchase an UHD HDMI cable. My conclusion is that newer LG TVs lose the HDCP 2.2 (High Bandwidth Digital Content Protection) info when the Roku is left idle, because I noticed when my SS+ Roku is first powered on, the remote works okay changing the TV HDMI input but never worked after it was left in the screen saver mode. Just make sure to leave the splitter power adapter plugged in. You may find cheaper splitters, just make sure it suits your needs because some don't come with power adapters or support 60Hz or don't support HDCP 2.0/2.2 etc.

Note:
LG TV's will NEVER be able to control a Streaming Stick Roku because the SS+ remote is NOT IR. (only non Roku Sticks have IR)

Re: LG tv wont switch source to Roku

Jump to solution

The problem seems to be a recent LG update with a new home screen format seems to have defaulted to forcing the LG home screen on power on which conflicts with Roku's 1-touch functionality for around 2 minutes. The solution is on the LG tv settings... All Settings > General > Add'l Settings > Home Settings > Home Auto Launch (disable).

This was driving me crazy and these settings are really well hidden. Might as well disable "Home Promotion" too, unless you like being fed ads on the LG Home page. You can also revert to the old LG Home screen format within this menu. 

mo_geezer
Newbie

Re: LG tv wont switch source to Roku

Jump to solution

Thanks for this detailed post.  Instructions just fixed two LG TV's that were driving us crazy!

0 Kudos
rickd24
Newbie

Re: LG tv wont switch source to Roku

Jump to solution

I've been having the same problem for the past couple of months. I checked the setting on my LG TV and it was already disabled. Oh well...

I'm wondering if it was a firmware update?

RokuJohnB
Community Moderator
Community Moderator

Re: LG tv wont switch source to Roku

Jump to solution

Hi @rickd24,

From the Roku Community, greetings and thanks for keeping us posted!

We want to further investigate this issue that you're experiencing. Can you please provide the following information below?

  • May we know what Roku device you're using right now? (Roku Express, Roku streaming stick, Roku Ultra, Roku streambar, Roku TV-Specify)
  • How are you powering your Roku device? Is it directly plugged into the wall outlet or into a power strip?
  • Have you tried switching HDMI outputs at the back of your TV to see if that will be able to fix the problem?

With detailed information, we will be able to assist you further.

Thanks,                                                                                                                                              John

John
Roku Community Moderator
0 Kudos
najak3d
Newbie

Re: LG tv wont switch source to Roku

Jump to solution

THANK YOU!!!  This fixed a major headache for us -- which was that "every time we turned off our TV, and then back on again later, the LG TV would REVERT back to the WebOS home screen!"

This would force us to pull out the TV Magic Remote, to reselect the ROKU!! (when we ALWAYS want it to be the ROKU, with few exceptions)

So the:
Settings => All Settings => General => System => Additional Settings => Home Settings => [TURN OFF ALL CHECKBOXES]

Fixed this for us!   Now when we turn off the TV (using ROKU remote), it KEEPS the ROKU as Input! (and even preserves the show/channel we were watching!).

So nice!  THank you for sharing this.

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.