Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
GMPRN
Channel Surfer

Hotspot 5g Brand New Onn Roku TV

I have a Moto stylus G 2022 T Mobile phone that I use as a hotspot. I cannot get my Onn Roku TV to connect. It shows I have excellent strength but "no internet." I do have Internet on the phone though. any help will be appreciated. In the past my fire stick would connect using the same hotspot but I couldn't connect to YouTube or YouTube TV. Now I can't connect at all to the Roku.

0 Kudos
14 REPLIES 14
RokuNimfa-C
Retired Moderator

Re: Hotspot 5g Brand New Onn Roku TV

Greeting @GMPRN,

Thanks for your first post in the Roku Community!

We're sorry to hear that you're having trouble connecting your new Onn Roku TV to your Mobile hotspot. To confirm, have you already completed setting up your Roku TV? We recommend that you try connecting your Roku TV directly to your home modem via an Ethernet cable to see if this resolves the issue.

To help troubleshoot the issue further, follow this link: How to connect your Roku streaming device to the internet using Wi-Fi or Ethernet

Keep us posted, we look forward to hearing back from you soon.


Regards, 
Nimfa

0 Kudos
makaiguy
Community Streaming Expert

Re: Hotspot 5g Brand New Onn Roku TV

5G refers to the fifth generation of mobile phone data connection protocols.

Perhaps you are referring to the hotspot operating in the 5GHz wifi band.  If so ...

The channels assigned to the 5 GHz band in ranges 50-64 and 100-144 are shared with other uses such as military, radar, and weather. These channels are termed DFS (dynamic frequency selection) channels and routers are supposed to automatically switch to a different channel if they detect one of these channels is in use in your area.

Roku and many other devices for home use devices avoid this whole issue by not supporting these DFS channels.    

Make sure your hotspot is not using these DFS channels, and that it is not using an auto select option that could choose a DFS channel.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos
GMPRN
Channel Surfer

Re: Hotspot 5g Brand New Onn Roku TV

Thank you for your response. I am unsure how to locate the channels to see if my phone's hotspot is using the DFS channels. I did a Google search and and I could only find information for routers, not a phone's hotspot.

0 Kudos
makaiguy
Community Streaming Expert

Re: Hotspot 5g Brand New Onn Roku TV

@GMPRN-

Upon further consideration, if the problem were caused by use of a DFS channel, the Roku would not have seen the hotspot at all for you to try to connect to it.

There is another possibility that describes your symptoms, i.e. finding the net, connecting to it, reporting a good connection strength, but not getting an internet connection.  It involves connections to the 2.4 GHz wifi band, not 5 GHz.  Perhaps your hotspot is set to use the 2.4 GHz band.

In the 2.4 GHz band if the hotspot is set to use g/n connection protocols Rokus will typically fail to connect.  Setting to b/g/n should correct this. 

But setting the hotspot to use the 5 GHz band would eliminate the b/g sutuation altogether.

Sorry, I don't have an iPhone to tell you how to find or set either if these.

 

 

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos
makaiguy
Community Streaming Expert

Re: Hotspot 5g Brand New Onn Roku TV

@GMPRN-

I found one reference that says the hotspot "maximize compatibility" setting determines the wifi band used by iPhone.

On = 2.4 GHz band

Off = 5 GHz band

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos
GMPRN
Channel Surfer

Re: Hotspot 5g Brand New Onn Roku TV

Thank you. I have a droid, not iphone. I think the hotspot is set to 5ghz, but it's kind of confusing. My husband's phone is a 4g phone, mine is a 5g phone. His phone's hotspot connects to the Roku with no issues.

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Hotspot 5g Brand New Onn Roku TV

@GMPRN 

On your Android phone, go to Settings/More/Cellular Networks/Access Point Names

Click on the Access Point that is listed/displayed.  Scroll down the info and look for "APN protocol".  It should be reporting IPv4/IPv6.  Roku devices currently do not support IPv6, so need to be seeing IPv4 listed under this protocol.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
GMPRN
Channel Surfer

Re: Hotspot 5g Brand New Onn Roku TV

Ok. It says ipv6. How can I change it to ipv4? Thank you!

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Hotspot 5g Brand New Onn Roku TV

@GMPRN

Easiest way is to follow the TMobile tutorial.  Just press Next to go to next step.

https://www.t-mobile.com/support/tutorials/device/t-mobile/revvlry/topic/connections-amp-network/apn...

Basically, you are just going to clone the existing APN (keep all the settings exactly as they are, but just change the APN Protocol and the APN Roaming Protocol to IPv4/IPv6.  Take screenshots or write down settings before changing them. (You can always "reset to default" if you run into issues.)

Sources with some instructions that may be helpful.

https://www.t-mobile.com/support/devices/not-sold-by-t-mobile/byod-t-mobile-data-and-apn-settings

Click on Android guide to expand instructions.

https://www.technobezz.com/updated-apn-settings-for-t-mobile/

Feel free to update this posting if you run into issues.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos