Roku mobile app

Discover troubleshooting and helpful tips for the Roku mobile app. Learn how to use the Roku remote on your phone, add channels, privately listen, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can’t connect in iOS 17.3

The Roku app on my iPhone suddenly can’t find any of my devices, but my iPad is having no problems. the only difference between them is the iPhone is on 17.3 and the iPad is still running 17.2, though, to be honest, I think maybe I updated the iPhone to 17.3 because this problem had already started. (I’m afraid I can’t quite remember.) I’ve tried restarting both the Roku and the iPhone and everything is up-to-date in terms of system updates. I also tried reinstalling the Roku app on the iPhone.

The only thing I haven’t done is reset network settings on the iPhone, because that is just too messy in terms of how it affects other apps. Any other ideas?

Labels (1)
Community Moderator
Community Moderator

Re: Can’t connect in iOS 17.3

Hello! @awsamuel,

We're thrilled to have you here in the Roku Community!

Thank you for reaching out to us about your Roku mobile. We're pleased to assist.

  • Have you tried signing out of the account and back in fix?
  • Is your phone or tablet connected to the correct Wi-Fi network? 
  • Is your iPhone permitted to access other devices over Wi-Fi?
  • Is your mobile device connected to a VPN? 

For more detailed information about how to connect your phone to a Roku streaming device with the Roku mobile app, visit our support page here.

Please keep us posted on what you find out, and we will be happy to continue assisting you further. We look forward to hearing back from you.



Roku Community Moderator
0 Kudos