Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Remote voice control stopped working

The voice control on my remote has quite working. I get a message on the screen that tells me that it can't hear me and try again. It never can hear me even if i yell at it.


0 Kudos
Roku Guru

Re: Remote voice control stopped working

Hello @ByronColley

Thanks for posting here in the Community.

Could you try re-pairing your remote to your Roku device to see if that will resolve the issue you're experiencing? To do this, please follow the instructions below:

  1. Remove the power cable from your Roku device, wait 5 seconds, and then re-connect the power cable.
  2. Wait until your Roku device displays the home screen.
  3. Restart your remote. If your remote uses standard batteries, restart your remote by removing and reinserting the batteries. If your remote is rechargeable, press and hold the pairing button for 20 seconds. The status light should slowly flash green, stop, then flash rapidly. When this happens, release the pairing button and your remote has restarted.
  4. Press and hold the pairing button for 5 seconds until you see the status light begin to flash. If the light does not flash, charge your remote or replace the batteries.
  5. Wait for 30 seconds while the remote establishes a connection with your Roku device.

Once the Roku device is connected to the remote, the pairing dialog should appear on your TV screen.

For more troubleshooting steps, check out this link: How to fix your Roku® voice or simple remote that is not working

Keep us updated!

All the best,

Kariza D.
Roku Forum Moderator
0 Kudos

Re: Remote voice control stopped working

I have 4 roku voice remotes.  Within the last month, 2 of the 4 no long have voice control.  I have tried everything.  My phone app works fine for voice control, and the other two remotes work fine on the systems that fail.  It appears to be the remote itself, however I find it very strange that two would stop working on two different tv within a week of each other. And yes, I have tried resetting and repairing many times

0 Kudos
Retired Moderator

Re: Remote voice control stopped working


Thanks for the post.

For clarification, the two remotes you are experiencing an issue with are Roku Voice Remote Pros that you paired to your Roku TVs?

With more detailed information, we will be able to assist you further.


Danny R.
Roku Community Moderator
0 Kudos

Re: Remote voice control stopped working

i also bought a voice remote pro, i haven’t even had it a month and the voice control is completely gone , one day it just stopped working…. i’ve tried everything from restarting it to repairing it , unplugging my tv. nothing works , not even 2 months old !!

0 Kudos
Retired Moderator

Re: Remote voice control stopped working


Thanks for reaching out here in the Roku Community.

Have you tried to re-pair your remote to the device? What troubleshooting steps have you taken so far to try to resolve the issue?
To help troubleshoot the issue further, follow this link: How to fix your Roku voice or simple remote that is not working

If the issue occurs again, please let us know along with the serial number of your Roku device where the remote is paired to.


0 Kudos
Reel Rookie

Re: Remote voice control stopped working

I have the same problem with my remote control. It stopped working on the 

Google assistant wont-work with it. The app on my phone still doesn't work. I don't know what the problem is. I've done all the repairing open remote control. I put new batteries in it. I unplugged the TV and it still doesn't work don't know why.  Try to to wake up to reconnect to the Google a system. It says it's connected but nothing will work not even on the Google assistants.

0 Kudos
Community Streaming Expert

Re: Remote voice control stopped working

@Opaboston, I don't have much help to offer other than Google assistant has nothing to do with the remote, so you can stop messing with the remote.  If you can't use your phone to control your Roku you might want to start there.  The phone and Roku have to be connected to the same network (as does the Google assistant device).  Try restarting your router.  Did it ever work?

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Reel Rookie

Re: Remote voice control stopped working

Sorry. Something? Went wrong. Try again. This is what I get each time even on my phone app it wont-work. I am on the same network. It just started doing this yesterday. It also did an update about 2 weeks ago. I'm wondering if that might have something to do with it.

0 Kudos
Retired Moderator

Re: Remote voice control stopped working

Hi @Opaboston,

Saw your post!

Thanks for letting us know about the behavior you're seeing with using the Roku Voice command feature using the Roku mobile app and all of the troubleshooting you've done.

We would like to ask you to attempt to try to uninstall the Roku Mobile app and Install it back. If that doesn't work, we request you to reply to us with the following information filled in below in order to make an effective suggestion:

  • Roku device model, serial number, device ID, and software OS/version (these can all be found in Settings > System > About)
  • brand, model, and current OS that the mobile device is running
  • version of the Roku mobile app that your mobile device is using
  • steps to reproduce the issue you are seeing

We look forward to hearing from you and looking closely into this issue. Thank you!

Best regards,

0 Kudos