Is your Roku TV not working? Join our online community forum to find help with common Roku TV issues, get troubleshooting tips, and share your experiences.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Streaming Star

eARC not working suddenly

TCL 65” Series 6. I have the Sonos Beam connected to the TV via ARC. Also connected: appletv. This has worked perfectly for 2 years. 

This week, I plugged in a DirecTV Gemini Air into the side HDMI port. This worked for about a week. The past few days, not so much. I get sound. That is fine. But the TV will lose the ability to control the volume. I either have to reboot the TV, or rescan CES. It happened twice tonight. From previous posts from, checks notes, two years ago (!!) people said there was a bug if you had multiple HDMI plugged in. Excuse me? Has this been figured out? It’s a **bleep** experience. 

Labels (1)
0 Kudos
Community Moderator
Community Moderator

Re: eARC not working suddenly

Hi, @rickeames 

Thanks for posting here in the Roku Community.

We appreciate you for sharing this information with us, and we understand the situation you've encountered with an error on multiple external devices plugged in your TCL Roku TV.

For this matter, it might be best to contact your Roku TV manufacturer since this is a hardware connectivity issue. Roku TV manufacturers provide direct support with their TV models, including troubles with connected external devices plugged in to the HDMI.

You can be guided here: Contacting Support for your Roku TV

We hope this will be sorted out. Let us know if there's anything we can do to help further. 

Best wishes,

Takashi O.
Roku Community Moderator
Streaming Star

Re: eARC not working suddenly

They do not handle the firmware and told me this was a firmware issue. So ball is back with you. 

0 Kudos
Community Moderator
Community Moderator

Re: eARC not working suddenly

Hi @MorganAlexander @rickeames,

Thanks for reaching out to the Roku Community.

We'd like to investigate and try to help regarding the issue you are experiencing when using eARC on your Roku device.

For us to better understand the issue you are experiencing, can you please provide us with more detailed information about the issue you are experiencing? Can you please provide us with the following information:

  • When did this issue first start occurring?
  • Was there a software update?
  • Roku device model, serial number, device ID, and software OS/version (these can all be found in Settings > System > About)
  • Tracker ID when this issue occurs (when you see this issue occur, quickly press Home 5 times and Back 5 times.)
  • Steps to reproduce the issue you are seeing

We're interested to know these details as we may be able to help you solve your issue. Your satisfaction means to us.

Best regards,
Roku Community Team

Mary F.
Roku Community Moderator
0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.