Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot connect app to Roku Express 4K

I just bought a brand new Roku Express 4K Model #:3940RW, Software Version 10.5.0

I made a Roku account, activated my device and I'm trying to use the app on my Google Pixel 6 and my Roku will not show up to connect to the app. I have tried to enter the IP address manually to force it to connect, but it says IP address does not exist and that I will have to try again. I have unplugged, let sit and replugged in the Roku and tried again, I have factory reset it, I've reset my phone, uninstalled and reinstalled the roku app, reactivated the Roku device, check for all updates and tried to use other devices to connect to it. I have had no luck at all in connecting any device to my Roku and it's really frustrating. Please help me figure this out, because as I'm a broke college student, I really wish I didn't waste my money on this piece of garbage.

0 Kudos
Community Streaming Expert

Re: Cannot connect app to Roku Express 4K

The Express and your phone have to be connected to the same Wi-Fi network.  In addition, some routers have a setting for client isolation that prevents one wireless device from communicating with another.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.