Roku setup

From linking a device to your account to adding channels, find Roku setup troubleshooting help and activation support from our community support forum.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

Re: Stuck on “Let’s Get Started” Screen

I was able to do a reset on my Roku Stick 4K by pushing and holding the reset button until the device blinked. I put batteries in the remote after that and it paired to the stick. I had to re-input network and Roku account credentials.


Re: Stuck on “Let’s Get Started” Screen

Just took my TCL Romulo tv out of box. I cannot get past the LET’S GET STARTED screen.


0 Kudos

Re: Stuck on “Let’s Get Started” Screen

I have this issue:  model 3920x. S/N


0 Kudos

Re: Stuck on “Let’s Get Started” Screen

I just bought a TCL 75R635 Roku TV from BestBuy, However its stuck on the Let's get started page. The remote doesn't work at all. I have also tried by reset however, nothing works. When I press the reset button long, TV enters into a recovery mode but I not action from the remote what so every. Details of the devices are below:

Version: 889.32R01171A

Serial Number: X00300KL7AHV

Device ID: S05GY19L7AHV

Roku TV: A115X

RCL Model: 75R635


0 Kudos
Retired Moderator

Re: Stuck on “Let’s Get Started” Screen

Hey @Rag1234

Thanks for reaching out here in the Community!

Have you tried contacting the TV manufacturer to inquire further? I'd suggest starting there to see what options or suggestions they can provide. Each Roku TV manufacturer provides direct support and warranty services for their products running the Roku OS.

For a list of Roku TV manufacturers contact information, visit our Community post here: Contacting Support for Your Roku TV

All the best,

Kariza D.
Roku Forum Moderator
0 Kudos

Re: Stuck on “Let’s Get Started” Screen

Model: 3930X 

SN: S01430AWSMN1

Roku Express Brand new just out of box, tried 2 sets of brand new batteries. 2 different tvs, reset internet, reset device everything that the roku website suggests doing and its still stuck on the let's get started select a language. 

I used my camera to see if the IR was working and all buttons except left right and okay work.

I live an hour away from the closest city that sells these and am honestly utterly disappointed. 

Hoping you can fix this, but i definitely wouldn't recommend this to anyone seeing as it seems like a common problem. 

0 Kudos
Community Streaming Expert

Re: Stuck on “Let’s Get Started” Screen

@TG123 wrote:

Looks like I solved it. I plugged the power supply into the TV USB instead of the mains.

I suspect the restart you got from unplugging/replugging was actually what solved your problem rather than powering via the tv's USB port.

There are two potential issues with using the tv's USB port.  Possibly neither of them will apply to you.  But just in case...

  • USB ports on many tvs, especially older ones, may not provide the current levels needed to operate a Roku reliably.  The Roku may start up okay, but if it runs into an activity that requires more power than the USB port can deliver, something has to give.  If you find the Roku starts dropping out of channel viewing and taking you back to the Roku home screen for no apparent reason, try plugging your Roku back into your house power through an appropriate USB power adapter.
  • The USB port on many tvs shuts down when the tv is turned off.  (On some sets, this may even be a configurable option.)  This means the Roku must boot up from a cold start each time you turn on the tv.  In some cases this only causes a minor inconvenience in that you must wait for the Roku to boot up before you can use it.  In others it can cause the initial HDMI information exchange between the tv and the Roku (commonly called it's "handshake") to fail if the tv starts this check before the Roku is ready to respond.  This can result in the tv reporting "no signal" or just showing a black screen for that HDMI port, or in some cases reporting an HDCP failure.


Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Ultra 4800 | Streaming Stick 4K+ 3821 | TCL Roku TV 43S245/C107X
0 Kudos
Not applicable

Re: Stuck on “Let’s Get Started” Screen

Rebooting hasn't worked for me at all. Holding down the reset button has no effect. Unplugging everything and then plugging everything back in hasn't worked. Any other ideas?

Community Streaming Expert

Re: Stuck on “Let’s Get Started” Screen

@NotCreative, I understand your frustration.  I'd return it, but it seems like that might be more hassle and costly than it's worth.  Since it sounds like the remote is faulty, you can go to pretty much any big box store and pick up a cheap universal remote that supports Roku.  There's no way to set it up without a working remote.

If you decide to return it:

Step by step instructions for returns and warranty replacements | Official Roku Support

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.

Re: Stuck on “Let’s Get Started” Screen

I had the same problem, tried EVERYTHING suggested, finally I removed the power cord connected to the back of TV and turned it around. It worked. Mind you, the TV was powering on and stuck on lets get started before I did that. Works fine now.

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.