Roku Direct Publisher

The easiest way to create a great TV experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Tylk
Level 7

Playback of channel missing, even if in preview it is looking good

I am encountering a strange issue, the test feed is validated and in the preview menu the feed/video  is looking as it must be. But, after the channel is added in the Roku instead of the menu and the video stream I have only the "Search" and "About" buttons and not the playable video stream.

 The feed was edited in the Json Feed Manager 2.0.3.0.

  The simple test feed is the following:

{
"lastUpdated": "2021-06-18T09:06:04+00:00",
"providerName": "TestTV",
"language": "en-US",
"liveFeeds": [
{
"id": "795b92398f9d4923a3a066e13477dba0",
"title": "Test TV",
"content": {
"dateAdded": "2021-06-18T20:27:10+00:00",
"videos": [
{
"url": "https://xxxxxxxx.xxxxxxxx.net/hls/live/xxxxxxx/xxxxxx/playlist.m3u8",
"quality": "HD",
"videoType": "HLS"
}
],
"duration": 86395,
"validityPeriodEnd": "2022-08-31T20:29:52+00:00"
},
"thumbnail": "https://www.xxxxxx/xxxx/xxxxx/xxxxxxx.png",
"brandedThumbnail": "https://www.xxxxx.tv/xxxx/xxxx/xxxxxxx.png",
"shortDescription": "Test TV",
"longDescription": "Test text",
"tags": [
"News"
],
"rating": {
"rating": "UNRATED",
"ratingSource": "MPAA"
},
"genres": [
"news"
]
}
],
"categories": [
{
"name": "News",
"query": "News",
"order": "most_recent"
}
],
"playlists": [
{
"name": "Test TV",
"itemIds": [
"795b92398f9d4923a3a066e13477dba0"
]
}
]
}

The published channel is like bellow. 

Honestly I don't know where to start debugging this problem, I'm out of ideas. Did happened to someone this kind of situation? 

20210618_212350.jpg

0 Kudos
3 REPLIES 3\
makaiguy
Community Streaming Expert

Re: Playback of channel missing, even if in preview it is looking good

This is for a channel you are creating/developing?

If so, you've posted to a forum for Roku users, where few, if any, will be able to help. The Developers forums are a couple of doors down the hall:  https://community.roku.com/t5/Developers/ct-p/channel-developers

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee, just a user like you.

Roku Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Roku Streaming Stick 3600
0 Kudos
renojim
Community Streaming Expert

Re: Playback of channel missing, even if in preview it is looking good

Or, if you're using Direct Publisher like it sounds like your are:

https://community.roku.com/t5/Roku-Direct-Publisher/bd-p/roku-direct-publisher

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
AaronMSpelling
Level 12

Re: Playback of channel missing, even if in preview it is looking good

@Tylk  nothing wrong with your feed 

that is an older Roku error , you need to contact the Roku Dev support and ask them for a fix. They usually fix it. 

There are tons of posts with the same error already on the forum.

use this to contact them it works a little bit faster then email  : https://developer.roku.com/contact

Building a TV Channel can be easy … if you have a right tools ===>> https://tv-channel.info/
0 Kudos