Roku Developer Program

Join our online forum to talk to Roku developers and fellow channel creators. Ask questions, share tips with the community, and find helpful resources.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
24i
Streaming Star

Rendering issue with images on top of a playing video

Hi,

We are running into a rendering issue when we try to loading images on top of a playing video.
The images are side-loaded from an API of our customer. 
If the image is received and rendered before the video starts playing everything is fine, but if the video started playing before the images are received/rendered the 'loadStatus' of the Poster node returns 'failed' and the image is therefore not shown. If we keep retrying to load/render the image from the same url, eventually it will render but takes a lot of time/retries...

Anyone else having this problem or knows a way to solve this? 
We can't wait for the images to be loaded and then start the video as we can't really do that check in the architecture that we have...
0 Kudos
4 REPLIES 4
Veeta
Visitor

Re: Rendering issue with images on top of a playing video

Once issue I have run in to is loading too many remote items at the same time.  There seems to be an upper limit on the number of HTTP requests happening simultaneously.  It could be that they are used up by the video player when it starts.  Another way I've experienced this is loading too many poster nodes at the same time, a number of them will fail.  One way around it is to preload the images to tmp:/ using AsyncGetToFile, otherwise your retry solution is probably the best.
0 Kudos
Tyler_Smith
Binge Watcher

Re: Rendering issue with images on top of a playing video

How big are the file sizes of your images?  Sounds to me like you're using up too much memory.
Tyler Smith
0 Kudos
24i
Streaming Star

Re: Rendering issue with images on top of a playing video

@Veeta
Doesn't seem like the problem as it also happens when loading just 1 image, for instance a channel logo or something.
We could try the "preload the images to tmp:/ using AsyncGetToFile" but probably won't work (see below the comment from Roku)

@Tyler Smith 
The file sizes are very low, so that can't be the problem.

So we contacted Roku themselves about this and this seems to be an issue on most devices:

You'll find that this type of functionality is not supported by the following devices:
- Giga 
- Jackson
- Tyler
- Paolo
- Sugarland
Otherwise, you'll have to wait for images to load before beginning video playback.
0 Kudos
NB_
Roku Guru

Re: Rendering issue with images on top of a playing video

"24i" wrote:
So we contacted Roku themselves about this and this seems to be an issue on most devices:

You'll find that this type of functionality is not supported by the following devices:
- Giga 
- Jackson
- Tyler
- Paolo
- Sugarland
Otherwise, you'll have to wait for images to load before beginning video playback.

Don't take that as a gospel - i asked around and the tech.person answering meant "not recommended because of performance concerns" (with such-and-such devices) which changed to "not supported" by whomever communicated it.

It's possible there is a bug that manifests only on low-end devices but can be addressed. Can you write some "minimal example" code that demonstrates this, to use as a basis for an issue? Also if you can report firmware#, player model#
0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.