Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

Plex logo not appearing on Plex tile

Hi - 

Starting yesterday, the Plex logo is missing from the Plex app tile on my Plex Home screen. The app is still present, I can still launch the Plex app by selecting the tile but the logo is now just a gray box. 

I've tried restarting the Roku several times and checking for updates, neither made any difference.

Community Streaming Expert

Re: Plex logo not appearing on Plex tile

A lot of people are reporting missing icons.  Try moving it by highlighting the missing icon and pressing * on your remote.  You can always move it back.  Let us know if that works.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
Reel Rookie

Re: Plex logo not appearing on Plex tile

Hi renojim - 

Thanks for the suggestion and that worked. No indication of the root cause, but it's good for now.

Channel Surfer

Re: Plex logo not appearing on Plex tile

Appears to have fixed for me as well... Thanks!

0 Kudos

Re: Plex logo not appearing on Plex tile

When I tried to move it, all the tiles went blank. The first two moves didn't help. Third time I moved it back to original spot, and *all* missing tile images were back. Just chilling in to encourage people to keep trying if it doesn't work on the first try.

0 Kudos
Roku Guru

Re: Plex logo not appearing on Plex tile

This is a bug in the recent middleware update. Several workarounds:

Run the app once, close out, then restart (pull power for a few seconds, or settings/system/power/system restart).

Do a move (everything will be blank), drop it, then it will reappear and you can move it back.

If you have the new option to set tile size in settings/Home Screen, you can open the app, close, then toggle the tile size back and forth. That worked on one Roku I have.

0 Kudos
Roku Guru

Re: Plex logo not appearing on Plex tile

Roku needs to do a much better job testing out updates to make sure there aren't any bugs before forcing these bad updates out on customers like this. Things like this can be extremely annoying and we shouldn't have to waste time moving icons around or rebooting devices to fix the glitches in their software. Luckily for me rebooting worked.

Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.