Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

I cannot watch live tv on the CTV Roku App but I can on the CTV iPhone app.

Hello, I am also having a similar issue. I cannot watch live tv on the CTV Roku App but I can on the CTV iPhone app. I have reinstalled the CTV Roku app and ensured my log in is correct. I am not using a VPN and these channels are available in my area as I am view them through my iPhone. How can this issue be fixed?

Labels (2)
0 Kudos
Community Moderator
Community Moderator

Re: CTV app not working correctly. Do I contact CTV or Roku about this issue?

A warm welcome here at the Roku Community, @Karli123618222!

We appreciate you reaching out regarding your playback issue with the CTV app. No worries; we're here to find you the best resolution possible.

Mentioning you've reinstalled the app, have you tried to perform a system reboot between removing and reinstalling it? (remove the app - system reboot - reinstall the app) We need to make sure that this troubleshooting procedure has been done precisely to work. 

Moreover, after performing those steps and the issue still persists, we highly recommend communicating with Customer Support of the CTV app for further advice and assistance.

We're eager to know your update! We're hoping to get everything sorted out soon.
Kind regards,

Carly Y.
Roku Community Moderator
0 Kudos
Reel Rookie

Re: I cannot watch live tv on the CTV Roku App but I can on the CTV iPhone app.

Yes i am getting the same error. I am logged into me Bell Fibe TV account and i cannot watch live channel from CTV. I contacted their helpdesk and they have escalated to Level 2 and opered a support ticket but it has been open for over 1 month now. 

On demand programs work but live channel i get "Protected Content License Error".  

I do not have this issue using the same login credentials on Fire TV stick of Google TV Chromecast. It works fine on these two platforms. It must be a bug specific to the CTV app on Roku platform.

I have deleted app, rebooted, re-logged in and same issue. No other live stream apps on my Roku have this issue.

protected content license error.jpg

Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.