Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can’t sign into Netflix upon password update

Having the same problem, Netflix works on IPADS, two Smart TVs but not my ROKU.  It worked until I bought a new IPAD and for some reason had to change my password to get it to work.  Now the ROKU doesn't work

 Device ID 85-264-872

Model    3100X  - Roku 2XS

SN 13C29A125485

Software   9.1.0  Build 5009-02




0 Kudos
Community Moderator
Community Moderator

Re: Can’t Sign into Netflix

Hi @DennisK1,

Welcome to the Roku Community!

Thanks for letting us know about this. We'd be more than happy to take a closer look at this.

When you updated your credentials on your Netflix, have you tried logging back into your Netflix account on Roku? If so, are you seeing an error message after that?

We also suggest reinstalling the app and performing a system restart from Settings>System>System restart before adding the channel back, then try again to see if it works.

If there's no improvement after doing that, we advise you to contact the channel support team directly about this and what they can suggest.

You can reach Netflix support here:

Let us know how it goes!



Roku Community Moderator
0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.