Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku won’t connect to wifi anymore. Please help?

Was working fine, it’s relatively new, maybe a year or so old. Never had any issues with it, went away for the weekend, now we’re back and it won’t connect to the wifi. Tried all the basic troubleshooting. Reset/restart, unplugged it, factory reset. Correct wifi SSID and password. Kinda at a loss at this point. How long do these usually last?

Labels (1)
0 Kudos
Community Streaming Expert

Re: Roku won’t connect to wifi anymore. Please help?

Who is your ISP, and do they provide your modem/router? If so, they likely changed a setting in the modem/router. You may or may not be able to change this setting yourself. comcast provides my modem, and locks me out of most settings. 

What you are looking for is on the 2.4 GHz radio settings, and it's labeled Mode. Yours is probably set to "G/N". There's another settings called "B/G/N", and that's what you need yours set to. There's no good explanation why the Roku needs that setting, and it's only with some specific router/modem hardware.


Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos

Re: Roku won’t connect to wifi anymore. Please help?

I was connected to 2.4hz and it kept saying connected and I would have no connection. Factory reset and it still would say connected but not connection. I found our 5hz Wi-Fi and connected to that and I’m back up and running!!! So I guess using a different network name I was able to get back up and running. Quite frustrating as a factory reset should completely reset the unit but it seems that the network is some how etched into the memory. Anyways - we are up and running. Try creating a new network.

0 Kudos