Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Excellent wifi but no internet connection

Jump to solution

It's all a big scam. This is my daughter's 2 tv in 2 years from it doing this same thing.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
makaiguy
Community Streaming Expert

Re: Excellent wifi but no internet connection

Jump to solution

@Jcj007n, @Jasonburd89 , @sandrabh22 -

There are some router setting issues that can prevent establishing Roku WiFi connections. And to make matters worse, some of them can be set by recently-reported router updates. These have primarily been reported with routers supplied by internet providers (Comcast/Xfinity, Cox, and AT&T so far), but it's possible they could also occur with other internet providers or user-owned routers that have received similar updates.

  • ROKU LOCATES NETWORK AND REPORTS NETWORK QUALITY BUT CANNOT CONNECT
    Some router updates have changed the router's connection settings on the 2.4 GHz WiFi band from b/g/n to just g/n, causing Rokus connecting to the 2.4 GHz wifi band to lose their ability to connect to the network.

    Note that, of recent Roku models, non-4K Roku Express/Express+ (model numbers below 3940) and Premiere/Premiere+ (model numbers above 4630) can ONLY receive the 2.4 GHz band and are therefore affected by this.

    The solution is to set the router's configuration back to using b/g/n.  See "Reconfiguring Router", below.
     
  • ROKU CANNOT FIND LOCAL WIFI NETWORK AT ALL
    If you have one of these situations, see "Reconfiguring Router", below.
     
    A) Some recent router updates have turned off dual band routers' use of the 2.4 GHz band. Some Roku models, notably Roku Express/Express+ non-4K models (model numbers below 3940) and Premiere/Premiere+ (model numbers above 4630), are lower end units with single band WiFi radios that only support the 2.4 GHz band. They, and many other devices of all sorts that are 2.4 GHz only, can't even see the 5 GHz band, let alone connect to it. If you have a 2.4 GHz only Roku model and a dual band router with both 2.4 and 5 GHz bands, be sure the router's 2.4 GHz band is turned on.
     
    B) In the 2.4 GHz WiFi band, all Rokus support channels 1-11, as are used in North America. If your router supports 2.4 GHz channels 12-14 that are used in other regions make sure your router is set to use a channel in the 1-11 range and that you aren't using an auto setting that could select channels outside this range.
     
    C) Rokus with dual-band WiFi radios can connect to the 5 GHz wifi band in two ranges of channel numbers, 36-48, and 149-165. Specifically they do NOT support the "DFS" channels 50-64 and 100-144. Many home use modems do not include the DFS channels but some do, so be sure your modem is set to NOT use DFS channels. If your router supports DFS channels and you can't turn them off, make sure you aren't using an auto setting that could select DFS channels.

Reconfiguring Router
Thanks to forum user @AvsGunnar  for providing the links below to instructions for reconfiguring router settings for the listed internet suppliers. If you can't do this yourself, you may need to contact your internet provider to make these changes for you:

If your problem was not caused by any of the above, often a restart of the router (even if other devices are still connecting) followed by a restart of the Roku will allow the connection to be reestablished. Depending on your Roku model and Roku version number you'll find the "System restart" option under either "Settings > System > Power" or "Settings > System", or if more convenient you can just remove the Roku's power for a few seconds and let it restart.

 

 

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Ultra 4800 | Streaming Stick 4K+ 3821 | TCL Roku TV 43S245/C107X

View solution in original post

4 REPLIES 4
RokuJanadeeK
Community Moderator
Community Moderator

Re: Excellent wifi but no internet connection

Jump to solution

Hi @Jasonburd89,

We apologize for this experience.

Would you mind elaborating on the issue you're having by answering the following:

  • May we know what specific device(s) are affected by this issue? (e.g., Roku Express, Roku Stick, Roku TV)
  • Are there any error messages?
  • What's the device's running OS? (You can check via Settings > System > About.)
  • What have you done so far to resolve this concern?

Please keep us informed so we can continue assisting.
Regards,
Janadee

Nadee K.
Roku Community Moderator
0 Kudos
sandrabh22
Reel Rookie

Re: Excellent wifi but no internet connection

Jump to solution

Mine is doing the same thing on all devices. This is ridiculous and can’t get anyone on phone. What exactly are we suppose to do? WiFi signal is good and device is updated. 

0 Kudos
Jcj007n
Reel Rookie

Re: Excellent wifi but no internet connection

Jump to solution

I can not get my tv re started. Internet is good. I powered off the tv. I have unplugged my tv several times. I restarted my router. My tv has just be stuck on channel update 1 of 96 updating ‘AirPlay for two days now. I have no clue what I can do to get pass this. 

0 Kudos
makaiguy
Community Streaming Expert

Re: Excellent wifi but no internet connection

Jump to solution

@Jcj007n, @Jasonburd89 , @sandrabh22 -

There are some router setting issues that can prevent establishing Roku WiFi connections. And to make matters worse, some of them can be set by recently-reported router updates. These have primarily been reported with routers supplied by internet providers (Comcast/Xfinity, Cox, and AT&T so far), but it's possible they could also occur with other internet providers or user-owned routers that have received similar updates.

  • ROKU LOCATES NETWORK AND REPORTS NETWORK QUALITY BUT CANNOT CONNECT
    Some router updates have changed the router's connection settings on the 2.4 GHz WiFi band from b/g/n to just g/n, causing Rokus connecting to the 2.4 GHz wifi band to lose their ability to connect to the network.

    Note that, of recent Roku models, non-4K Roku Express/Express+ (model numbers below 3940) and Premiere/Premiere+ (model numbers above 4630) can ONLY receive the 2.4 GHz band and are therefore affected by this.

    The solution is to set the router's configuration back to using b/g/n.  See "Reconfiguring Router", below.
     
  • ROKU CANNOT FIND LOCAL WIFI NETWORK AT ALL
    If you have one of these situations, see "Reconfiguring Router", below.
     
    A) Some recent router updates have turned off dual band routers' use of the 2.4 GHz band. Some Roku models, notably Roku Express/Express+ non-4K models (model numbers below 3940) and Premiere/Premiere+ (model numbers above 4630), are lower end units with single band WiFi radios that only support the 2.4 GHz band. They, and many other devices of all sorts that are 2.4 GHz only, can't even see the 5 GHz band, let alone connect to it. If you have a 2.4 GHz only Roku model and a dual band router with both 2.4 and 5 GHz bands, be sure the router's 2.4 GHz band is turned on.
     
    B) In the 2.4 GHz WiFi band, all Rokus support channels 1-11, as are used in North America. If your router supports 2.4 GHz channels 12-14 that are used in other regions make sure your router is set to use a channel in the 1-11 range and that you aren't using an auto setting that could select channels outside this range.
     
    C) Rokus with dual-band WiFi radios can connect to the 5 GHz wifi band in two ranges of channel numbers, 36-48, and 149-165. Specifically they do NOT support the "DFS" channels 50-64 and 100-144. Many home use modems do not include the DFS channels but some do, so be sure your modem is set to NOT use DFS channels. If your router supports DFS channels and you can't turn them off, make sure you aren't using an auto setting that could select DFS channels.

Reconfiguring Router
Thanks to forum user @AvsGunnar  for providing the links below to instructions for reconfiguring router settings for the listed internet suppliers. If you can't do this yourself, you may need to contact your internet provider to make these changes for you:

If your problem was not caused by any of the above, often a restart of the router (even if other devices are still connecting) followed by a restart of the Roku will allow the connection to be reestablished. Depending on your Roku model and Roku version number you'll find the "System restart" option under either "Settings > System > Power" or "Settings > System", or if more convenient you can just remove the Roku's power for a few seconds and let it restart.

 

 

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Ultra 4800 | Streaming Stick 4K+ 3821 | TCL Roku TV 43S245/C107X