Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Denies WIFI password and tries to update software but progress is 0% - error code 014.30

4 days ago my Roku express stopped working - has been fine before.  I've repeatedly gone through all the steps - I have the correct password for my WIFI - it works on every other device in the house incl. the bedroom Roku.  It's not finding it although it is immediately above the router.  It then states initializing software updates but progress never goes beyond 0%.  This is a newer Roku I bought when I got the email my old one was out of date.  Lights flash on it when I've tried to connect so it does have power.

0 Kudos
Community Streaming Expert

Re: Denies WIFI password and tries to update software but progress is 0% - error code 014.30


In order to test the Roku Express hardware connection ability, try connecting via a hotspot if available to you.  

Depending on your Roku Express model which can be found under Settings/System/About, any Roku Express other than the new 3960 model will operate only on the 2.4ghz band of your network.  If you have a cable ISP like Xfinity/Cox, Comcast, or AT&T, you will likely need to verify that your router's wireless mode is set to b/g/n.

If you have already tried restarting both your router and the Roku device, and the above is applicable to you, it is likely the router's wireless mode setting may be the culprit. (firmware updates to cable ISP routers have been causing issues with some 2.4ghz devices like the Roku for some time now by having difficulty connecting when set to g/n rather than b/g/n).

Feel free to post an update or if you still need more help.  Provide the Roku model number, the router model number, and your ISP (internet service provider).

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
Community Streaming Expert

Re: Denies WIFI password and tries to update software but progress is 0% - error code 014.30


Error code 14.30 indicates a lack of a network connection.  The Roku can't update, or complete an update, or stream anything, if it has no network connection.

This being a Roku Express (not a 4K Express model, I'm assuming, since you didn't mention 4K - it's always a good idea to include the model NUMBER as found with Settings > System > About when seeking help) it is a budget model with a single band WiFi radio that only supports the 2.5 GHz WiFi band. 

Your router may have received an update which made some setting changes for the 2.4 GHz band that cause your problem.  These changes have been reported with routers supplied by internet providers (Comcast/xfinity, Cox, and AT&T so far), but it's possible they could also occur with other internet providers or user-owned routers that have received similar updates.

When you say "it's not finding it", are you saying when you do a Settings > Network > Set up connection > Wireless it does not list your home network?  If so, this can be caused by router updates which:

  • Switched the 2.4 GHz WiFi band off entirely, leaving just the 5 GHz band active.  Any other devices you have that connect via the 5 GHz band will continue to connect.  Be sure your 2.4 GHz WiFi band is turned on.

    Or ...

  • Set your 2.4 GHz settings to use a channel not supported by your Roku.  Rokus only support 2.4 GHz channels 1 through 11 as are used in North America.  Channels 12 & 13 as are used elsewhere are not supported.  If your router supports 2.4 GHz channels above 11, be sure it is set to use a channel within the 1-11 range, and not an "auto" setting that could select channels above 11.

If a scan of your networks DOES find your home network, reports network quality, but then fails to give you an internet connection, this can be caused by a different router configuration change which:

  • Changed your 2.4 GHz network connection parameters from from b/g/n to just g/n, causing Rokus connecting to the 2.4 GHz wifi band to lose their ability to connect to the network.  The solution is to set the router's configuration back to using b/g/n.

Thanks to forum user @AvsGunnar for providing the links below to instructions for reconfiguring router settings for the listed internet suppliers. If you can't do this yourself, you may need to contact your internet provider to make these changes for you:

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X