Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
GreatOffender
Reel Rookie

DNLA No Longer Connecting

This is not a new issue and I have researched it extensively. Relatively new 55" onn. w/ Roku built in and all software updated. Wifi sees it as TCLRokuTV-3JA. I have permanently assigned it an ip address and confirmed this address thru Roku and the router.

I have a raspberry pi 3 using miniDNLA as a server for music, videos, etc. After an update to the pi the entire system went down and I was forced to rebuild it. Sever was always visible to the Roku and now it is not. I have 2 Roku's, 2 FireSticks, and 2 Google TV dongles and they all connect except for this TV.

I did reboot the router and the server was visible briefly but the connection was no longer available 60 min later? I have since tried rebooting the router to no avail. This is done wireless and connection strength is "Good". What's the issue? Roku gives no control over the connection so I am at the mercy of the device.

side note - my app no longer seems to connect or control the Roku either and this is new.

0 Kudos
3 REPLIES 3
RokuLianna
Retired Moderator

Re: DNLA No Longer Connecting

Hi @GreatOffender

Welcome to the Roku Community!

If your DLNA server is no longer connecting to your TCL Roku TV, there are a few things you can try to troubleshoot the issue:

  • Verify that the server is running: Make sure that the miniDLNA server is running on your Raspberry Pi and that it is configured properly. You can check this by connecting to the server from another device on your network, such as a laptop or smartphone.
  • Verify that the Roku TV is connected to the correct network: Ensure that your TCL Roku TV is connected to the same network as your Raspberry Pi and other devices on your network.
  • Reset network settings on Roku: Try resetting the network settings on your TCL Roku TV by going to Settings > System > Advanced system settings > Network connection reset. Then set up the network connection again from scratch.
  • Try using a wired connection: If you're currently connecting your TCL Roku TV wirelessly, try connecting it to your network via a wired Ethernet connection instead. This can help to eliminate any potential wireless connectivity issues.

Regarding the issue with your app not connecting to and controlling your Roku TV, try uninstalling and reinstalling the app on your phone. If this doesn't work, try restarting your phone and then reconnecting to the same network as your TCL Roku TV.

Please keep us posted on what you find out.


Warm Regards,
Lianna

0 Kudos
GreatOffender
Reel Rookie

Re: DNLA No Longer Connecting

Thank you for the suggestions but this issue was well researched before I posted. My only error was the TV type being TCL and not onn.

Server is visible to several other Roku devices.

Roku is connected to the network and the IP address of the device has been made static on the router.

Network has been reset several times. Connection = Good!

I would not try a wireless connection if wired was available.

The server did appear once after rebooting the router but disappeared shortly after. This Roku is new and worked 100% until the day it didn't.

0 Kudos
AvsGunnar
Community Streaming Expert

Re: DNLA No Longer Connecting

@GreatOffender 

When you launch the Roku Media Player (RMP), try backing out of it (keep pressing Back button on remote), all the way back to Home Screen.  Then enter RMP again.  You may have to back out of it a few times for the RMP to refresh connections.  I have a couple different DLNA servers running, (one constant through a router), and others on different laptops (intermittent and only active when laptop is powered on).  When I boot the laptops, I may have to Back out of RMP a few times until RMP recognizes it.  Other times it will recognize it immediately.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos