Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku Ultra says my tv is not capable of hdcp 2.2

Hi all. I have a 4k UHD television connected to a Roku Ultra (which I love by the way). Every single time I wake my tv and roku up to watch TV, I check the display settings only to see that it tells me my TV isn't compatible with hdcp 2.2. (Second checkmark) but the first checkmark says I am capable of playing 4k at 60 fps. It's not a huge deal because I literally unplug it and plug it back in and it fixes the issue and the picture looks great.. But I have to do EVERY SINGLE TIME I turn my TV back on. I've tried 3 different hdmi cords and 2 different hdmi ports. Ive turned off 'auto adjust refresh rate' and tried turning down the subsampling to 4:2:0. It seemed to help at first but now it's back to doing it every time. What should I do?

Labels (1)
0 Kudos
Retired Moderator

Re: Roku Ultra says my tv is not capable of hdcp 2.2


Thanks for the post.

If you connect your device to another TV, are you experiencing the same issue?

In addition, can you please provide us with the following information: Roku device model, serial number, device ID, and software OS/version (these can all be found in Settings > System > About)

With more detailed information we will be able to assist you further.


Danny R.
Roku Community Moderator
0 Kudos

Re: Roku Ultra says my tv is not capable of hdcp 2.2

I am facing this issue as well with a brand new Roku Ultra. I am using the HDMI cable it came with. The same solution of unplugging and replugging works, but is really annoying. Was there any solution here?

0 Kudos
Community Streaming Expert

Re: Roku Ultra says my tv is not capable of hdcp 2.2

@ZaxR, try disabling "power saving" under Settings->System->Power.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos