Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku Express 4K crashes on Advanced Display Settings, won't play 4K HDR content

My Roku Express 4k (3940 series) won't play HDR content when connected to my 4k HDR monitor - it definitely did previously.

Also on boot, I get a black screen if it tries to play any video, but not in menus - I have to go to display settings, change to 4k, play a video - at this point I only get the top left ¼ of the content so have to go back again and select 4k HDR again, at which point I can watch content, however it is in 4k, not 4k HDR (even for 4k HDR available content).

I tried going to "advanced display settings" to debug this, and found that even hovering over that entry in the menu crashes the entire system and after around 15-30 seconds it reboots.

I've tried a system reset to fix this, however it hasn't fixed anything, so it seems like either a system update has broken something, or some hardware in the device has failed.

I can still play 4k HDR content using my desktop PC, so it seems unlikely that it is the display or the cable which is causing the issue.

Community Moderator
Community Moderator

Re: Roku Express 4K crashes on Advanced Display Settings, won't play 4K HDR content

Hi @1rre

Welcome to the Roku Community!

We understand that you're having a problem with your HDR content since it will not play. Help is here. Please click this link and follow the steps: How to set up your Roku® streaming player for HDR

If the problem still persists, please keep us posted.

All the best,


Roku Community Moderator
0 Kudos