Roku setup

From linking a device to your account to adding channels, find Roku setup troubleshooting help and activation support from our community support forum.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Setting up 4K streaming stick. Updates software and will no longer respond

Just got my Roku Streaming Stick 4K.  Connected up fine... then it said it detected a software update.  OK, waited while it went through that process and got a screen that said I had the most up to date software and there was a button at the bottom that said CONTINUE.  I can NOT get the remote to respond any longer.  I found a post that said to hit the *, so I did.  Nothing but the Roku logo water-falling down the screen.  Tried hitting the reset button on the remote.  Tried hitting home, tried removing and reinserting the stick... nothing.  Help please.

0 Kudos
Community Streaming Expert

Re: Setting up 4K streaming stick. Updates software and will no longer respond


If you remove only the Streaming Stick from the HDMI port, you are disconnecting the video and audio signal.  In order to restart the Streaming Stick, you will need to unplug the USB power cable from your power supply (ie, either the USB power port or the adapter at the wall).

When you tried "hitting the reset button on the remote", assuming maybe you mean the pairing button in the battery compartment.


First, just try restarting/rebooting the Streaming Stick.  Unplug the Streaming Stick from power supply for a few seconds, plug back in, and let it reboot. If still no-go, try restarting your router.

The remote may need to be re-paired to your device.  Try pressing the pairing button in the battery compartment of the Roku remote for 5 secs or so until it flashes, then reboot the Streaming Stick again.  Wait a few moments and see if the pairing circle appears on screen. More details on pairing here  

You can also download the official mobile Roku Remote app from the Apple/Play stores to use with your Roku device as a remote while addressing the physical remote issue.


Normally, trying a factory reset (pressing and holding the Reset button for 30+ seconds on the Streaming Stick) is recommended as a last resort, but not advised when you do not a functioning remote as you need a working remote in order to proceed through setup.  Try using the mobile app and attempt to re-pair the remote to your device first before attempting the factory reset.  Sometimes may take a couple of re-pair attempts.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102