Roku setup

From linking a device to your account to adding channels, find Roku setup troubleshooting help and activation support from our community support forum.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rawkhopper
Newbie

Roku won’t move past updating channels

 

I manually triggered an update on my device. Roku Premiere Plus.  It wouldn’t do the final update and gave me the option to try again or do factory reset.  I hit try again 3 times and decided to do a factory reset.  It seemed to work as it let me verify the device with my email but then it says Updating channels and it has been sitting there with that on the screen for 30mins.  Please help me fix this.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0 Kudos
2 REPLIES 2
RokuMary-F
Community Moderator
Community Moderator

Re: Roku won’t move past updating channels

Hi @rawkhopper,

Thanks for your first post in the Roku Community!

We understand that you are facing an issue with the Roku device. We'd be happy to take a closer look to see how we can help get you up and running.

Just to verify, how are you powering your Roku device? Is the device plugged into the TV USB port or is it plugged into a wall outlet? 

if you are still experiencing an issue, we would recommend disconnecting your wireless network, then rebooting your Roku device to see if your Roku device is experiencing the same issue.

Please keep us posted and we'll continue assisting you from there.


Best regards,
Mary

Mary F.
Roku Community Moderator
0 Kudos
makaiguy
Community Streaming Expert

Re: Roku won’t move past updating channels

@RokuMary-F-

Please take @rawkhopper's report at face value.   I think Roku's back end had some problems today.

This was all on the Roku Streaming Stick 4K+ listed in my signature.

When I tried to remove a channel earlier today by highlighting it on the Roku Home page channel grid and pressing the * key on my remote, this just showed the revolving buffering arrow and eventually timed out, not producing the expected dialog from which I could remove the channel.  I tried to access the info for two or three other major channels with the same result.

So I then went to check for a software update, and again got the rotating buffer arrow for a minute or so that did not respond to key presses.   I pressed the Back and Home keys repeatedly and eventually it just jumped back to the previous Software update page.

I restarted my Roku from the Power menu and when I tried the update check again, it led to a "no internet connection" error message, which was obviously in error since I was able to stream from a variety of channels with no problem.  Doing a connection check confirmed there was no problem and reported a download speed of around 150 Mbps.

As a result of this thread I tried it all again, and everything is now working as it should.  The update check completed and updated several channels.  I was able to remove that one unwanted channel.  So whatever the backend problem was apparently has been taken care of.

 

 

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Ultra 4800 | Streaming Stick 4K+ 3821 | TCL Roku TV 43S245/C107X
0 Kudos