Roku Direct Publisher

The easiest way to create a great TV experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 12

Re: Feed Issue, no videos showing up (Newbie)

Bigmike333 and all others with this problem...

For my unpublished (test) channel, I do, in fact, rename my feed file each time I make a change because I want my changes reflected immediately.  I use Amazon's CloudFront caching and if I don't rename the file (ie. I use the same name), the changes are not reflected until the cache has been refreshed.

There must be some other condition, as I stated earlier in this thread, that is contributing to the "bug".  How else would I be able to continue to update my channel?  Is it possible that there's a problem in the actual feed file?  For example, a stray BOM in the file.  I know early on when I first started creating my Json feed file, I had problems with the file and the use of a BOM in the file.  That's one of the reasons I decided to write my own software to create and manage Json feeds.
FREE Windows desktop software for creating and managing Direct Publisher MRSS, JSON, and FireTV feeds @ https://github.com/rrirower. No Programming knowledge required.
0 Kudos
Highlighted
Level 8

Re: Feed Issue, no videos showing up (Newbie)

I downloaded your trial version of the software. Is there a comprehensive set of instructions for it that explain what each element of the program does, formats, changes, etc? It is well laid out, but I have no idea how it puts out a json file to upload. Even if it did, it would crash on Roku. The json file I have been using worked in the past. All I changed was the url for the live stream, which plays fine in VLC, and plays fine after I go ahead and publish the channel. The only way to preview it though, is to actually publish the channel. This is not a good plan. My channel worked, but how many will not?
0 Kudos
Highlighted
Level 12

Re: Feed Issue, no videos showing up (Newbie)

Big mike333...

I'm not sure what you mean by a "comprehensive list of instructions".  The software does come with a Help file that explains how to use it.  If you've got specific questions, please PM me, or, contact me through the website in my signature.
FREE Windows desktop software for creating and managing Direct Publisher MRSS, JSON, and FireTV feeds @ https://github.com/rrirower. No Programming knowledge required.
0 Kudos
Highlighted
Level 8

Re: Feed Issue, no videos showing up (Newbie)

Hi Guys,

UPDATE:
As of  June 24th, 2019... the issue seems to have been "FIXED" already... I was able to create unpublished channels, delete, add new, and all working fine now!!!

Hopefully it stays fixed Smiley Happy

Thank you all who contributed to this thread Smiley Happy
0 Kudos
Highlighted
Level 7

Re: Feed Issue, no videos showing up (Newbie)

Did the problem come back?
In my test channel, when I do a "preview" from the panel (roku web), the screenshot shows the thumbnails and categories.
But if I enter the channel on my roku device (it is not yet published, I install the test channel using the code provided by roku), it shows the presentation screen, the logo and only 2 icons: (search and information).

0 Kudos
Highlighted
Level 11

Re: Feed Issue, no videos showing up (Newbie)

yep the bug is still there , randomly  , some regions , some channels , some time .........  and the answer from Roku is the same 

they know about the issue

general issue 

they are working on it

they will update you ........

 

 

Building a TV Channel can be easy … if you have a right tools ===>> https://tv-channel.info/
0 Kudos
Highlighted

Re: Feed Issue, no videos showing up (Newbie)

I'm having this exact problem.  Is the bug solved if you just go straight to publish the channel? 

JSON: https://riiactive.com/wp-json/tv/roku/

Thanks!!

 

EDIT: After publishing, my channel is now working.  

0 Kudos
Highlighted
Level 7

Re: Feed Issue, no videos showing up (Newbie)

Same problem, wasted a whole day on this.

It should not be necessary to publish (waiting 2 weeks!?) just for testing purposes.

Extremely frustrating for new developers who want to quickly integrate.

Highlighted
Level 7

Re: Feed Issue, no videos showing up (Newbie)

I am having the same issue here. Unpublished channel, feed status shows no errors, preview works, but no videos show in the channel on Roku device. This seems it has been an issue for over a year!! How has this not been fixed yet?? Are there any workarounds besides publishing the channel? I actually do not want to publish because I intend to keep my channel private and unpublished.

0 Kudos
Highlighted
Level 7

Re: Feed Issue, no videos showing up (Newbie)

it shows the presentation screen, the logo and only 2 icons: (search and information).

The same for my test unpublished channel.

just got from support:

 

Our engineering team has deployed a fix for several channels that were only seeing a Search and About icon in their Direct Publisher channels. However, we are not sure if this particular fix addressed all the issues reported over the last few weeks due to the wide variety of channel reporting this issue.

But still all the same.

0 Kudos