Roku Direct Publisher

The easiest way to create a great TV experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 10

Re: Feed Issue, no videos showing up (Newbie)

"Bigmike333" wrote:
Well, looks like another two weeks has come and gone with no ability to test unpublished channels. Also, Roku is tinkering with adding things to your published channels you may not appreciate. Such as a huge search icon that allows your viewers to search within your channel, even if you have only one icon the viewer can click on, as most of my channels are set up this way to connect to live streams. Now there's two icons, one of which is useless, and it throws off the balance and look of my background images. By the way, you can't make it go away. Please let them know if this bothers you, as it is best to nip this in the bud before they populate this to all Direct Publisher channels. How about we fix this preview problem first, instead of adding excess junk to developer's channels?

Where do you see this 'tinkering' as I haven't seen that. Smiley Sad
0 Kudos
Highlighted
Level 9

Re: Feed Issue, no videos showing up (Newbie)

I have not seen this on my channel, either.
0 Kudos
Highlighted
Level 12

Re: Feed Issue, no videos showing up (Newbie)

Today, I updated my Json feed for my test channel (unpublished).  It took longer than normal to update, but, it worked.  And, when I opened the channel on my device, I did not receive any errors.  The new videos were all available.

I mention this because I don't know if the Roku problem is officially fixed.  I have not seen any kind of announcement.
FREE Windows desktop software for creating and managing MRSS, JSON, and FireTV feeds @ https://github.com/rrirower. No Programming knowledge required.
0 Kudos
Highlighted
Level 8

Re: Feed Issue, no videos showing up (Newbie)

The new "features" are being migrated into the Direct Publisher channels. It's only hit one of mine so far, and man is it ugliness. Support told me we will have to live with it. If you want to look a it, search out America Matters TV and install the channel. Normally, there is only one clickable icon that comes up, with the logo. If the show is live on the air, the show will begin playing when you click that logo. Otherwise, it reverts back to the home screen. Look below the main icon and see the search icon Roku has inserted. Click on that and look at the ugliness... When they put that icon on there, it moved everything up and out of balance with my background image. This is not in my json feed, I can assure you of that.
0 Kudos
Highlighted
Level 9

Re: Feed Issue, no videos showing up (Newbie)

Here is what they look like if you're interested: 

https://imgur.com/a/mwR1mFK
0 Kudos
Highlighted

Re: Feed Issue, no videos showing up (Newbie)

Has there been any resolution on this? I am still having trouble with my unpublished channels... as soon as you launch it throws error: "there appears to be a problem. please try again" and just crashes.... this has been going on weeks now. What is the deal?

I even deleted the channel and started over from scratch and still the same issue.
0 Kudos
Highlighted
Level 9

Re: Feed Issue, no videos showing up (Newbie)

"avodahsoftware" wrote:
Has there been any resolution on this? I am still having trouble with my unpublished channels... as soon as you launch it throws error: "there appears to be a problem. please try again" and just crashes.... this has been going on weeks now. What is the deal?

I even deleted the channel and started over from scratch and still the same issue.

I have an idea. Make another Roku account, make your channel based on another developer account (with another email address)
0 Kudos
Highlighted
Level 8

Re: Feed Issue, no videos showing up (Newbie)

"mosafer" wrote:
"avodahsoftware" wrote:
Has there been any resolution on this? I am still having trouble with my unpublished channels... as soon as you launch it throws error: "there appears to be a problem. please try again" and just crashes.... this has been going on weeks now. What is the deal?

I even deleted the channel and started over from scratch and still the same issue.

I have an idea. Make another Roku account, make your channel based on another developer account (with another email address)

Hi,
I have actually done this on post #15, I actually used another Roku device with another roku developer account that is bound to that other device... created channel...still no progress, same issue.
Update as of June 7, 2019... still same error on my end, "there appears to be a problem. please try again" something then it just closes and goes back to Home... this is for different developer accounts, different unpublished channels... error still persists.
Thanks,
Paul
0 Kudos
Highlighted

Re: Feed Issue, no videos showing up (Newbie)

Same here... I can't get anything to work on unpublished channels. Any update from Roku, anybody else?
0 Kudos
Highlighted
Level 8

Re: Feed Issue, no videos showing up (Newbie)

Baradanikto

If you rename your json file to anything different than the one you are using, and then have the Feed Status check it, your private channel will be inoperable from that point on. Not suggesting you do this, but the bug still persists.
0 Kudos