Roku Direct Publisher

The easiest way to create a great TV experience.
cancel
Showing results for 
Search instead for 
Did you mean: 
elivate
Level 7

Feed Issue, no videos showing up (Newbie)

Hi,

Thank you very much for welcoming me here.  My apologies but this is a newbie question and really need expert's help.

I created a channel and added all necessary info and images.  Categories were selected on the Roku Developer option.
Everything is checked on the Feed Status and no errors when checking the Feed.  We also used all possible validators online and json is valid.
My issue is on Roku device, it shows the splash page, then it seems to load (progress circle), then that disappears, and nothing else, it stays blank.

Feed URL:
https://account.drtestimonial.com/channel/15.json

Thumbnails/Videos do not load, it stays blank.  Although Roku Developer accepted the feed without error and it published it.

Kindly asking for expert's advice if there is something missing on our feed, or an error, or anything.
Also, is it okay to use AWS S3 for video hosting and use the Youtube image like I did on the feed?
Any opinion, suggestion, correction, anything... is highly highly appreciated!!!

Thanks,
Paul
0 Kudos
33 Replies
Baradanikto
Level 9

Re: Feed Issue, no videos showing up (Newbie)

I validated your feed file using my software and it does appear to be valid.  However, I did notice that you do not define any categories in the feed file.  Hopefully, you've defined then through the developer portal using the tags you specified in the feed file.  Your videos and thumbnails are both accessible so, there's no problem with Amazon S3.  However, you should consider using Amazon's CloudFront caching service for streaming your content.

Some things to try:


  • I know that you cannot stream directly from YouTube.  Have you tried using a thumbnail image that's stored on AWS?

  • Check that your categories on the Developer Portal reference the tags you specified in the feed file.
Windows desktop software for creating and managing MRSS, JSON, and FireTV feeds @ https://rrirower.wixsite.com/software. No Programming, JSON or MRSS knowledge required.
0 Kudos
elivate
Level 7

Re: Feed Issue, no videos showing up (Newbie)

Hi Baradanikto,

Thank you very much for the reply, it is highly appreciated.

1. I can try to upload the images on AWS and see if that will help, although I used to do that same Youtube image url and it seems to work before, but I will try your suggestion.
2. I did specify the category/ies on the Roku Developer section together with the Tags specified on the feed, I might try to specify Category/ies via feed and see if this will fix it.

Not really sure why it is not showing anything on my device.  I had to scan the feed and compare with the other ones that are working and they seem be in accordance (except inclusion of Category which I define via Roku Developer Admin).

I will try both suggestion and will update post if anything happens.

Other suggestions/opinion/comments are welcome.

Thank you very much.
Paul
0 Kudos
37mediagroup
Level 9

Re: Feed Issue, no videos showing up (Newbie)

My guess is Youtube doesn't work for the images. Reason being it also doesn't work for video hosting, due to a URL shortening format. I read that the videos URL (example: www.youtube.com/video/1b4hts879x024 is generally a shortened or redirect to the true URL path, which is more along the lines of youtube.com/path/videos/user198376/video=19273464828992 or something like that. Essentially, much, much longer.

Wouldn't surprise me if the same thing happens as a result with images. I think there's server side scripting redirecting it to its native URL path, but the redirect doesn't work via Roku. Something like that. I would try another image host or hosting them at AWS
0 Kudos
elivate
Level 7

Re: Feed Issue, no videos showing up (Newbie)

Hi Guys,

Thanks 37mediagroup, I did what you suggested.

I did both suggestions:

1. I added category on feed and updated Roku Developer Admin
2. I uploaded the images to AWS

Nothing happened, still blank, I had a test link to see if the updates above worked, but to no avail.
Please see my json if the file is valid or I still need to do some more adjustments.

Feed URL:
https://account.drtestimonial.com/channel/15.json

thank you so much.
0 Kudos
37mediagroup
Level 9

Re: Feed Issue, no videos showing up (Newbie)

Did you manually add the "tags" into each category in the Roku Dashboard? 

For instance: Category "Health"  Tags: "Sleep Apnea" "Whitening" "Invisible Braces"
0 Kudos
elivate
Level 7

Re: Feed Issue, no videos showing up (Newbie)

Hi 37mediagroup,

I tried both:
1. Fetch Category from json/feed, then Action below
2. Manually add "Health" then added the tags, then Action below

Action:
Used the temp url Roku Developer provides, still blank
Deleted the channel on my Roku device, then added again, still blank, no errors, just stays blank after the rotating status circle...

I will try on another hosting (dedicated server with true url/path)... not sure if AWS is causing this issue... will update you guys if this action will at least do something


Thank you very much for helping me out... I am at my wit's end... totally baffled...
0 Kudos
elivate
Level 7

Re: Feed Issue, no videos showing up (Newbie)

Hi,

Just a small experiment I have done.

First
I uploaded all files video and images to a dedicated server,
https://account.drtestimonial.com/channel/15.json
Created a new test channel, added the test add code, does not work

Second
I created a new channel and copied everything from a working channel... again, error says like "something went wrong and try again later"

I am starting to believe there is some issue with my developer account?

Thanks again
0 Kudos
Baradanikto
Level 9

Re: Feed Issue, no videos showing up (Newbie)

I'll take a look at your updated feed file. In the meantime, check the permissions you have set on your server. Make sure you've provided public access.
Windows desktop software for creating and managing MRSS, JSON, and FireTV feeds @ https://rrirower.wixsite.com/software. No Programming, JSON or MRSS knowledge required.
0 Kudos
Baradanikto
Level 9

Re: Feed Issue, no videos showing up (Newbie)

I took a quick peek at your feed file. You've defined one category, however, your query is incorrect. The query needs to be one or more tags from your video items.
Windows desktop software for creating and managing MRSS, JSON, and FireTV feeds @ https://rrirower.wixsite.com/software. No Programming, JSON or MRSS knowledge required.
0 Kudos