Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
ljunkie
Level 7

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

"EnTerr" wrote:
Brightscript Debugger> ? FindMemberFunction(createObject("roVideoPlayer"), "SetConnectionTimeout")
<Interface: ifHttpAgent>

Interesting! So can i venture a guess that everything that implements ifHttpAgent is (d)effected?

I immediately went there too when I noticed what implemented it, but after limited testing, that doesn't seem to the case. The roTextutreManager and roTextureRequests look unaffected as well as the roUrlTransfer. The other listed we don't use, so I can't say. It seems though that Roku may have just set the "player" components with the default 5 second timeout, but I'll defer to them as they are the only ones that can provide which components now have a 5 second timeout. 
0 Kudos
Highlighted
RokuDale
Level 9

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

The timeout change has the limited scope of the component.
0 Kudos
Highlighted
EnTerr
Level 9

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

"RokuDale" wrote:
The timeout change has the limited scope of the component.

Sorry, that's a bit unclear...
You mean that only the instances from roVideoScreen/roAudioPlayer/roVideoPlayer have their default timeout shrunk to 5 sec?
And on the flip side, all other ifHttpAgent implementors now too have SetConnectionTimeout() available but with a different default?
0 Kudos
Highlighted
RokuDale
Level 9

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

The change only affects the videoplayers use of http agent. All other users of httpagent are not affected.
0 Kudos
Highlighted
EnTerr
Level 9

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

"RokuDale" wrote:
The change only affects the videoplayers use of http agent. All other users of httpagent are not affected.

got it, thanks!
0 Kudos
ljunkie
Level 7

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

"RokuDale" wrote:
The change only affects the videoplayers use of http agent. All other users of httpagent are not affected.


It also affected the roAudioPlayer. I assume 7099 has the timeout fix? Haven't tested yet since we've since added the workaround. Will have to verify later.
0 Kudos
Highlighted
RokuDale
Level 9

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

4099 does.
0 Kudos
Highlighted
nwjon
Level 7

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

ljunkie, please can you post an example of the workaround? 
0 Kudos
Highlighted
renojim
Level 13

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

Did you read the whole thread?
0 Kudos
Highlighted
nwjon
Level 7

Re: roVideoPlayer and roVideoScreen timeout issues on 7.5 firmeware

Yes, i still dont get it.
0 Kudos