Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
cpjamloki
Level 7

minimum firmware version

i am not understanding the concept of minimum firmware version during publishing my channel. please explain the concept behind it.
0 Kudos
5 Replies
bbrouse
Level 7

Re: minimum firmware version

The value set for minimum firmware version is the lowest firmware version your channel will be available for install.

For example, if you select v3.1 (which I believe is all older Roku players) then your channel will be available on all Roku players that have version 3.1 or higher installed (3.1, 4.0, 5.0, and so on). If you select, for example, v5.1, then your channel will not be available on any firmware version older than 5.1, but will be available on all players that have firmware version 5.1 or newer installed.
0 Kudos
destruk
Level 10

Re: minimum firmware version

For process improvement, there should be a choice added for 'any' instead of using 3.1, as 3.1 is the lowest available firmware with the forced firmware updates. (would simply eliminate confusion on the numbers)
0 Kudos
cpjamloki
Level 7

Re: minimum firmware version

as suggest by destruk there is "any" option but i do't found "any" option there during submission my channel. there is lowest version v2.5 b388 and max v6.2b1 .
so you mean i should select v2.5 b388 version for all devices.
0 Kudos
destruk
Level 10

Re: minimum firmware version

3.1 or lower would cover everything.
0 Kudos
TheEndless
Level 7

Re: minimum firmware version

You need to make sure your channel will run on firmware 3.1 devices before making it available to them.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
0 Kudos