Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
EnTerr
Level 9

Re: Trouble setting theme attributes from a URL.

"dratio" wrote:
I've also just now noticed something else that is weird... I have assigned the same web-based image to both HDBackgroundImageUrl and HDSmallIconUrl and their SD counterparts, and lo and behold it displays on HDSmallIconUrl! So, when the same web-based image is displayed in both HDBackgroundImageUrl and HDSmallIconUrl, all is well. However, if a different web-based image is assigned to HDSmallIconUrl, it will not display.

Oh... now that you say it like that - YES!

There is a bug that causes that. Really sneaky. I ran into it when i worked with roListScreen few months ago but did not bother to mention it since i already report way too many bugs "per capita". (Somebody may think i get paid to dig dirt on B/S)

My experience was that HDSmallIconUrl / SDSmallIconUrl do not show up unless i have set the same image in HDPosterUrl / SDPosterUrl. My un-educated guess of why this is happening would be that a cache akin to roTextureManager is used internally for the images and *SmallIconUrl fetches from there but does not pre-load URLs unlike *PosterUrl and *BackgroundImageUrl

By the way, HDSmallIconUrl / SDSmallIconUrl are not documented anywhere so one may argue you are not supposed to use them Smiley Happy

PS. And on another note, HDPosterUrl / SDPosterUrl are also undocumented for roListScreen but might be actually the ones you want to use instead of HDBackgroundImageUrl / SDBackgroundImageUrl. I was startled to discover *PosterUrl @ roListScreen.
0 Kudos
dratio
Level 7

Re: Trouble setting theme attributes from a URL.

"EnTerr" wrote:
"dratio" wrote:
I've also just now noticed something else that is weird... I have assigned the same web-based image to both HDBackgroundImageUrl and HDSmallIconUrl and their SD counterparts, and lo and behold it displays on HDSmallIconUrl! So, when the same web-based image is displayed in both HDBackgroundImageUrl and HDSmallIconUrl, all is well. However, if a different web-based image is assigned to HDSmallIconUrl, it will not display.

Oh... now that you say it like that - YES!

There is a bug that causes that. Really sneaky. I ran into it when i worked with roListScreen few months ago but did not bother to mention it since i already report way too many bugs "per capita". (Somebody may think i get paid to dig dirt on B/S)

My experience was that HDSmallIconUrl / SDSmallIconUrl do not show up unless i have set the same image in HDPosterUrl / SDPosterUrl. My un-educated guess of why this is happening would be that a cache akin to roTextureManager is used internally for the images and *SmallIconUrl fetches from there but does not pre-load URLs unlike *PosterUrl and *BackgroundImageUrl

By the way, HDSmallIconUrl / SDSmallIconUrl are not documented anywhere so one may argue you are not supposed to use them Smiley Happy

PS. And on another note, HDPosterUrl / SDPosterUrl are also undocumented for roListScreen but might be actually the ones you want to use instead of HDBackgroundImageUrl / SDBackgroundImageUrl. I was startled to discover *PosterUrl @ roListScreen.


Interesting. Thanks for all the info I really appreciate it and I will try using the PosterUrl. Then I guess I would just set background and smallIcon to the same Url and it would display. Thanks again!
0 Kudos
Roku Employee
Roku Employee

Re: Trouble setting theme attributes from a URL.

"EnTerr" wrote:
(Somebody may think i get paid to dig dirt on B/S)


You could:
https://www.roku.com/about/employment

- Joel
0 Kudos