Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
casolorz
Level 7

Trouble playing videos using ECG since the last update

A lot of my users are reporting issues playing videos. My app uses ECG to send the videos to the Roku. Every user having issues has 7.1.0 4062-06. I have -04 and can't reproduce the issues.

Has anyone else experienced this?

Thanks.
0 Kudos
10 Replies
casolorz
Level 7

Re: Trouble playing videos using ECG since the last update

A user has just informed me that the play on roku functionality of the official roku app also doesn't work for videos. I'm guessing it is related.
0 Kudos
Roku Employee
Roku Employee

Re: Trouble playing videos using ECG since the last update

"casolorz" wrote:
A lot of my users are reporting issues playing videos. My app uses ECG to send the videos to the Roku. Every user having issues has 7.1.0 4062-06. I have -04 and can't reproduce the issues.

Has anyone else experienced this?

Thanks.


Can you be more specific as to the kind of video playback issues, and what is the video UI (roVideoScreen, ?) in your app?
Including video format information might be helpful.
And what do you mean by ECG exactly?
0 Kudos
EnTerr
Level 8

Re: Trouble playing videos using ECG since the last update

Me and Wikipedia (https://en.wikipedia.org/wiki/ECG) think it must be ElectroCardioGram.

That's exciting news! I mean, if iPhone can measure my pulse with its camera, why couldn't Roku take my ECG via the radio-remote? Smiley Tongue
0 Kudos
casolorz
Level 7

Re: Trouble playing videos using ECG since the last update

And what do you mean by ECG exactly?


This is ECG https://sdkdocs.roku.com/display/sdkdoc ... trol+Guide

Anyways, the videos are just normal web videos, for example https://media.w3.org/2010/05/sintel/trailer.mp4

That video works perfectly for me on my Roku 3 but the users complaining of this issue can't play it. The same users have been using the app for several months and nothing has changed in terms of how videos are sent to the Roku.

Also no videos stored on the phone are working anymore for those users using Play On Roku through the Roku app. I even made some of them download the video listed above and they were unable to send it to the Roku using the Roku app. I'm able to send it just fine.
0 Kudos
Roku Employee
Roku Employee

Re: Trouble playing videos using ECG since the last update

"casolorz" wrote:

This is ECG https://sdkdocs.roku.com/display/sdkdoc ... trol+Guide

What ECP command(s) are you using specifically?

"casolorz" wrote:

That video works perfectly for me on my Roku 3 but the users complaining of this issue can't play it. The same users have been using the app for several months and nothing has changed in terms of how videos are sent to the Roku.

I'm still not clear what you mean by "how videos are sent to the Roku" from the app. Does your app use roVideoScreen or what?

"casolorz" wrote:

Also no videos stored on the phone are working anymore for those users using Play On Roku through the Roku app. I even made some of them download the video listed above and they were unable to send it to the Roku using the Roku app. I'm able to send it just fine.

I did some tests here previously with a 7.1.0 4062-06 and did not have any trouble playing videos from Roku app on iPhone or Android device.
I can see if the specific video you mentioned is an issue, though I'm not sure offhand how to import that into the mobile app.
0 Kudos
casolorz
Level 7

Re: Trouble playing videos using ECG since the last update

In the guide I linked you can find this command:

curl -d '' 'http://192.168.1.134:8060/launch/dev?streamformat=mp4&url=http%3A%2F%2Fvideo.ted.com%2Ftalks%2Fpodcast%2FVilayanurRamachandran_2007_480.mp4'

It very similar to how I send videos. I send videos using the same stuff as Play On Roku which is like this:

http://" + host + String.format("15985?t=v&u=%s&k=(null)&h=%s&videoName=%s&videoFormat=%s",
encode(url),
encode(host),
encode(title),
encode(mediaFormat))


The only reason I think the issue is with 7.1.0 4062-06 is because every one of my users who has reported the issue has that version. They all seem to be on older Roku models. I have a Roku 3 and can not reproduce the issue.
0 Kudos
Roku Employee
Roku Employee

Re: Trouble playing videos using ECG since the last update

"casolorz" wrote:
In the guide I linked you can find this command:
curl -d '' 'http://192.168.1.134:8060/launch/dev?streamformat=mp4&url=http%3A%2F%2Fvideo.ted.com%2Ftalks%2Fpodcast%2FVilayanurRamachandran_2007_480.mp4'

It very similar to how I send videos. I send videos using the same stuff as Play On Roku which is like this:


As the documentation describes, the example is for the side-loaded app and assumes you have that as simplevideoplayer.
Are you using simplevideoplayer in this example, or your app is based on simplevideoplayer?

But I'm not clear where a ECP command would come into customer usage, other than for developer test purposes, or how that has anything to do with video playback issues (?).
Have you tried debugging the parameters that are passed to your app to make sure they appear correct, perhaps in a 'secret' diagnostic screen?
0 Kudos
casolorz
Level 7

Re: Trouble playing videos using ECG since the last update

Like I said, I'm not using that command, I am using the same command that Play On Roku uses. My app doesn't have a Roku channel, all it does is call the command I sent (not the one on the guide). My app casts over 2 million videos per month to various streaming devices, Roku used to account for 6 to 7% of those 2 million videos, and now Roku accounts for 4 to 5%, so obviously there is an issue, but it doesn't affect everyone. I know of two other Android apps that do the same thing as mine and neither is working anymore for those users (at least the ones that have tested it).

I haven't tried any kind of troubleshooting on my end because I can't not reproduce the issue with my Roku and my firmware.

Why don't we forget about my app for a minute and just focus on the users being unable to use the Roku app to send videos using Play On Roku? Once that is fixed for them then I'm 100% certain my app will work again. What can I tell the users to do or try in order to get this fixed? I should mention a couple of the users already tried factory resets and it didn't help.
0 Kudos
EnTerr
Level 8

Re: Trouble playing videos using ECG since the last update

"casolorz" wrote:
Why don't we forget about my app for a minute and just focus on the users being unable to use the Roku app to send videos using Play On Roku? ... What can I tell the users to do or try in order to get this fixed? I should mention a couple of the users already tried factory resets and it didn't help.

Good idea! Where are these "user reports" though?!
Usually there would be topic in the General forum with people bitching about the issue. Pointers?

@RokuKC -
any chance of fixing https://sdkdocs.roku.com/display/sdkdoc ... trol+Guide page title be "External Control Protocol" instead of "External Control Guide"? Esp. considering confusion with EPG (Electronic Program Guide aka Electronic Content Guide)
0 Kudos