Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
nowhereman
Level 7

Startup Delay with Streaming Audio

As most of you know, I'm building an Internet Radio channel and I've run into some interesting behavior. It seems as though the longer you use the channel, the longer it takes for a given stream to start playing. When you first launch the channel, streams start almost immediately, but after listening to other streams for a while, those same streams can take several seconds and in some cases minutes to start playing. It's almost as if the player is silently playing out any existing buffered data before it will start playing the new stream.

I've experimented with the streambitrates to no avail

I have tried different combinations of calling the AudioPlayer's Stop() and ClearContent() functions between streams with no luck.

I've seen others mention similar behaviors, but I have not seen anyone come up with a fix. Am I doing something wrong or is this an issue with the box itself? If the latter, is there a fix coming? And is there any sort of workaround?
twitter:nowhereman
http://www.thenowhereman.com/roku
http://www.thenowhereman.com/netflix
0 Kudos
9 Replies
Narsh
Level 7

Re: Startup Delay with Streaming Audio

I've been wondering about this and searching for a fix too. If there is a way to assure the audio plays promptly I hope someone will post the solution here. Do any of the Roku devs have any advice on this issue?
0 Kudos
hotw00
Level 7

Re: Startup Delay with Streaming Audio

I'm stunned there hasn't been a response on this from the Roku team. I'm hoping they've PM'd you about the problem privately.

For all the work you've done on the excellent channels you've been working on I would've expected at least a "We'll PM you" nod from the devs.

Keep up the great work on your channels, by the way. You've turned this device from a wonderful movie machine to an "Oh my God I don't want to live without it" gadget.
0 Kudos
Anonymous
Level 8

Re: Startup Delay with Streaming Audio

Looking into it.
0 Kudos
nowhereman
Level 7

Re: Startup Delay with Streaming Audio

"hotw00" wrote:
I'm stunned there hasn't been a response on this from the Roku team. I'm hoping they've PM'd you about the problem privately.

For all the work you've done on the excellent channels you've been working on I would've expected at least a "We'll PM you" nod from the devs.

Keep up the great work on your channels, by the way. You've turned this device from a wonderful movie machine to an "Oh my God I don't want to live without it" gadget.


Roku did PM me shortly after my original post. They have actually done quite a bit to support and encourage my development efforts.
twitter:nowhereman
http://www.thenowhereman.com/roku
http://www.thenowhereman.com/netflix
0 Kudos
hotw00
Level 7

Re: Startup Delay with Streaming Audio

"nowhereman" wrote:
"hotw00" wrote:
I'm stunned there hasn't been a response on this from the Roku team. I'm hoping they've PM'd you about the problem privately.

For all the work you've done on the excellent channels you've been working on I would've expected at least a "We'll PM you" nod from the devs.

Keep up the great work on your channels, by the way. You've turned this device from a wonderful movie machine to an "Oh my God I don't want to live without it" gadget.


Roku did PM me shortly after my original post. They have actually done quite a bit to support and encourage my development efforts.


I was hoping that was the case.

Thanks for your contribution to this device/platform, nowhereman. We're enjoying some streaming Whole Wheat Radio via RadioTime on this Saturday morning.

Thanks dev team and Roku management for deciding to build your product with an open model for independent/private channel development!
0 Kudos
Narsh
Level 7

Re: Startup Delay with Streaming Audio

"RokuPatrick" wrote:
Looking into it.

Thank you, Patrick. I hope you will share your findings here for other developers to see as well as in the PMs to nowhereman.
0 Kudos
renojim
Level 10

Re: Startup Delay with Streaming Audio

Has this issue been fixed with the latest firmware? I don't see it occurring anymore, but it was kind of intermittent in the first place.

-JT
0 Kudos
Anonymous
Level 8

Re: Startup Delay with Streaming Audio

"renojim" wrote:
Has this issue been fixed with the latest firmware? I don't see it occurring anymore, but it was kind of intermittent in the first place.

-JT

It's been improved considerably if not outright fixed.
0 Kudos
renojim
Level 10

Re: Startup Delay with Streaming Audio

Thanks. It's definitely much better and like I said I haven't seen a case of buffering taking a long time since the new firmware.

Thanks for your efforts!
-JT
0 Kudos