Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
joetesta
Level 10

Request: Stop requiring support of devices 5+ years old

In this modern day, Roku models 2450 and 2500 have a horrible user experience.  Most major device manufacturers (eg Apple) do not support devices 5+ years old as 2450 and 2500 now are.
There may be some legitimate masochists out there but I suspect any statistical numbers of users above 0 are just Roku developers testing and comparing their apps on such ancient devices.
I think it would be better for the users if they were not misled by the fact that Roku requires support of these 5+ year old devices.  Because for anyone who's used a "modern" device like a Roku 3 Smiley LOL, these are barely usable.

Cable companies could send these out to convince people not to become cord cutters  Smiley LOL
aspiring
0 Kudos
2 Replies
Komag
Level 9

Re: Request: Stop requiring support of devices 5+ years old

I used to keep a 2500 around for testing, but I found it to be only slightly slower than the 2710, so I ended up giving away the 2500 to a friend who was still using an old 2050 up until last year!
0 Kudos
joetesta
Level 10

Re: Request: Stop requiring support of devices 5+ years old

wow!  I have a 2710 which feels pretty slow and outdated but apparently is not as much so as the 2450 and 2500, which are failing things the 2710 passes :/
aspiring
0 Kudos