Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 

Port 8060

Hi

I have a Roku 4200 running on the locat network:
172.150.1.195

I am timing out when I try to telnet on port 8060
telnet 172.150.1.195 8060

And I get nothing using a GET to from the browser
http://172.150.1.195:8060/query/apps

This used to work for me.

Has there been some restriction added in later firmware?

Thanks for any advice
James
0 Kudos
14 Replies
belltown
Level 7

Re: Port 8060

You could try taking it out of Developer Mode then re-enabling Developer Mode.
https://github.com/belltown/
0 Kudos
Komag
Level 9

Re: Port 8060

What's 8060 for?
0 Kudos
TheEndless
Level 7

Re: Port 8060

8060 is the ECP port. I don't think you can telnet to 8060, so that failed connection is probably expected.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
0 Kudos
EnTerr
Level 8

Re: Port 8060

"TheEndless" wrote:
8060 is the ECP port. I don't think you can telnet to 8060, so that failed connection is probably expected.

Nah. If destruk can http to 8085, am i any worse not to telnet 8060? :mrgreen:
$ telnet 192.168.1.25 8060
Trying 192.168.1.25...
Connected to roku-2xs.gateway.pace.com.
Escape character is '^]'.
GET /query/apps HTTP/1.0

HTTP/1.1 200 OK
Server: Roku UPnP/1.0 MiniUPnPd/1.4
Content-Length: 2492
Cache-Control: no-cache
Content-Type: text/xml; charset="utf-8"

<apps>
<app id="12" type="appl" version="3.1.6040">Netflix</app>
...
</apps>
Connection closed by foreign host.
$

@jamesrdelaney - is the Roku PING-able?
Is the client you are trying to connect from also on 172.150.1.*?
What's the firmware# ?
0 Kudos
TheEndless
Level 7

Re: Port 8060

"EnTerr" wrote:
"TheEndless" wrote:
8060 is the ECP port. I don't think you can telnet to 8060, so that failed connection is probably expected.

Nah. If destruk can http to 8085, am i any worse not to telnet 8060? :mrgreen:
$ telnet 192.168.1.25 8060
Trying 192.168.1.25...
Connected to roku-2xs.gateway.pace.com.
Escape character is '^]'.
GET /query/apps HTTP/1.0

Now that's curious. I actually tried it before posting and got a failed connection. Testing just now, I got the same. I'm testing on my Roku 4, though, so maybe it's locked down in 7.0...?
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
0 Kudos
renojim
Level 9

Re: Port 8060

EnTerr, what firmware are you on? I couldn't connect to any of three different boxes running three different versions of firmware.

-JT
0 Kudos
EnTerr
Level 8

Re: Port 8060

"renojim" wrote:
EnTerr, what firmware are you on? I couldn't connect to any of three different boxes running three different versions of firmware.
i checked on 6.2.3468, 6.2.3675
"TheEndless" wrote:
Now that's curious. I actually tried it before posting and got a failed connection. Testing just now, I got the same. I'm testing on my Roku 4, though, so maybe it's locked down in 7.0...?
You guys are scaring me. I doubt the Co will do something so dickish as intentionally blocking the whole of ECP w/o warning. Does "Roku by Roku" app work with your players? How about remoku.tv and other apps?
0 Kudos
Highlighted
destruk
Level 10

Re: Port 8060

When I try to telnet to a roku4 on 8060 it sitas there, control-C returns -
HTTP/1.1 400 Bad Request
Server: Roku UPnP/1.0 MiniUPnPd/1.4
Content-Length: 0
Connection to host lost.

So it probably 'connects' or it wouldn't know it was a roku server, but just doesn't handshake. 8060 does the same thing on my roku3 too.
0 Kudos
TheEndless
Level 7

Re: Port 8060

"EnTerr" wrote:
"renojim" wrote:
EnTerr, what firmware are you on? I couldn't connect to any of three different boxes running three different versions of firmware.
i checked on 6.2.3468, 6.2.3675
"TheEndless" wrote:
Now that's curious. I actually tried it before posting and got a failed connection. Testing just now, I got the same. I'm testing on my Roku 4, though, so maybe it's locked down in 7.0...?
You guys are scaring me. I doubt the Co will do something so dickish as intentionally blocking the whole of ECP w/o warning. Does "Roku by Roku" app work with your players? How about remoku.tv and other apps?

Yes, ECP still works. I'm using PuTTY to try and connect, so maybe it's sending a character the telnet connection doesn't like.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
0 Kudos