Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
malloys
Level 7

Re: New Eclipse Plugin Release 12/17/12

"venrooy" wrote:
Hi, I've done that but here is what I get... It doesn't seem to have the section there where I can open a template - like the simplevideoplayer:


I'm not able to reproduce this on any of my clean test installations, so I'll need more information...

1) Clear the Error log (via the Error Log view), restart eclipse, attempt to use the BrightScript Project wizard, and then let me know if there are any new errors in the error log.
2) Which specific package and version and of Eclipse are you using?
3) Which specific operating system type and version are you using?

Cheers
0 Kudos
miroppb
Level 7

Re: New Eclipse Plugin Release 12/17/12

I installed Eclipse IDE for Java, but when I try to install BrightScript, I get an error:
Cannot complete the install because one or more required items could not be found.
Software being installed: BrightScript Core 1.0.0.201301111057 (com.roku.brightscript.ide.eclipse.core.feature.group 1.0.0.201301111057)
Missing requirement: BrightScript Plugin 1.0.0.201301111057 (com.roku.brightscript.plugin 1.0.0.201301111057) requires 'bundle org.eclipse.dltk.core [2.0.0,2.1.0]' but it could not be found
Cannot satisfy dependency:
From: BrightScript Core 1.0.0.201301111057 (com.roku.brightscript.ide.eclipse.core.feature.group 1.0.0.201301111057)
To: com.roku.brightscript.plugin [1.0.0.201301111057]


I'm on Win8 x64, and I run eclipse under admin, but this still happens.
0 Kudos
malloys
Level 7

Re: New Eclipse Plugin Release 12/17/12

I'm guessing you missed this line in the installation section of the Eclipse plugin guide :

" If you are trying to run on eclipse 3.7 Indigo or later, you will have to add a couple of other update sites to get the DLTK 2.0 dependencies automatically resolved. These update sites are: http://download.eclipse.org/modeling/em ... /releases/ and http://download.eclipse.org/technology/dltk/updates/ "

Cheers
0 Kudos