Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"renojim" wrote:
"rraheja" wrote:
Thanks JT - I am going to try one of the videos with just framerate of 29.97 and see if it works fine after a reboot. If it doesn't I will try to upload a copy somewhere for debugging. My router is a Linksys E2000 and both the server and Roku are connected to it, so not sure if it would be a router issue. Photos and Music plays fine, so hoping that it is not a Windows Vista firewall issue either.

Keep us posted.


Update on my continuously reloading issue...

I created three handbrake encoded versions of my one of my dvd titles; all with Normal profile, Web Optimized (-O) and framerate 29.97.
V1: bitrate 3200 (using Constant RF=20) ... still takes a long time to retrieve and then reloads within seconds. Filesize approx 550MB
V2: bitrate 2000 ... slightly faster to retrieve, reloads after a few minutes and then every 15-30 seconds or so. Filesize approx 350MB
V3: bitrate 1000 ... much faster to retrieve, reloads a few times only. Filesize approx 275MB

So bitrate seems to affect my Roku; although I am able to play Netflix HD without any issues!
My topology is as follows:
Roku connected via Wireless-N to Linksys E2000 router.
Laptop running MyMedia server connected via Wireless-G to Apple Airport Express Base Station.
Apple Airport Express Base Station wired connection to Linksys E2000 router.

You can find a small sample of the V1 file - please see if you can play without reloading.
http://dl.dropbox.com/u/2261749/Sample-3Mbps-2997-RF20.m4v

The server log file does not show any errors - only multiple 206 partial content repeat requests. Only odd thing I found was that when starting server, it registers using the correct IP address but then shows 0.0.0.0:8001 even though it shows the directories and is able to find the media fine.

Thanks for your help!
0 Kudos
Highlighted
Level 19

Re: My Media - Your Music and Video on the Roku DVP

I tried your video and the only time I got any reloading was when I used my laptop as the server. It's connected via Wireless-G as is my Roku. Using either my desktop or Dockstar (Pogoplug) as a server, which are both wired, I didn't get any reloading. Even with the laptop, most of the time I didn't get any reloading and if there was any it was only one time during the video.

Can you try a wired connection to your server (and/or your Roku) and see if it helps?

-JT
0 Kudos
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"renojim" wrote:
herbertbrubaker, what version of the firmware is on your box? It's under "Settings", "Player Info".

-JT


Jim

I just upgraded my box to 1521 and now all is fine - the videos play as they did before 1509
Going where the wind don't blow so strange
0 Kudos
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

I am having difficulty getting MyMedia to work with my new Roku.
I hope to access video which is on my mac from the MyMedia channel.
On the mac, I had Python 2.3.3 already installed,
I installed additionally, Python 2.7.1
I installed libpng and libjpeg (combo package)
When I attempt to install PIL, and copy and paste the command:
sudo easy_install --find-links http://www.pythonware.com/products/pil/ Imaging
into Terminal, I first get the prompt to type my password, after entering my password, then I get:
sudo: easy_install: command not found
I never get to a message that jpeg support is available.
Further attempts only give me this same error message with no possibility of entering a password.
Do you have any suggestions what I might try?
Thank You

New update:
After installing PIL using an installer. I did get the message near the end of the install that jpegs were supported
also that Tkinter was supported.
When I launch springboard.py, I get the server configuration window, enter the information, click "install client" and see

writing configuration
uploading ../zips/client.zip to http://10.0.1.8:80/plugin_install
multipart/form-data; boundary=----------ThIs_Is_tHe_bouNdaRY_$

then I click "launch server" and get:
writing configuration
Exception in Tkinter callback
Traceback (most recent call last):
File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/lib-tk/Tkinter.py", line 1345, in __call__
return self.func(*args)
File "/Applications/netguy204-roku_media_server-25aaa89/server/springboard.py", line 168, in launch_server
panel = ServerPanel(root, self.spawn_server())
File "/Applications/netguy204-roku_media_server-25aaa89/server/springboard.py", line 182, in spawn_server
import subprocess
ImportError: No module named subprocess

I get an empty window tk #2

Any ideas why this exception is occurring, an how I can resolve it?
Thank You
0 Kudos
Highlighted
Level 19

Re: My Media - Your Music and Video on the Roku DVP

"dellsweig" wrote:
I just upgraded my box to 1521 and now all is fine - the videos play as they did before 1509

That's great, but I had hoped we were past firmware updates causing things to stop working.

-JT
0 Kudos
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"renojim" wrote:
I tried your video and the only time I got any reloading was when I used my laptop as the server. It's connected via Wireless-G as is my Roku. Using either my desktop or Dockstar (Pogoplug) as a server, which are both wired, I didn't get any reloading. Even with the laptop, most of the time I didn't get any reloading and if there was any it was only one time during the video.

Can you try a wired connection to your server (and/or your Roku) and see if it helps?

-JT

SOLVED

You are right. The issue only happens on wireless laptop, not when wired!

My Wireless-G shows Excellent Strength and 54Mbps speed but as soon as media starts streaming, the speed drops down to 48 then 36,24, 11, 5,5,2 and finally rests at 1Mbps. That is when the reloading issue comes up. I suspect the two wireless routers close together may be causing that, so I disabled the G router; and used only N and it fixed it, but I still occasionally get speeds drop to 1 or 2Mbps (though not as often). So need to investigate my location and any other interference.

Interestingly with wired, even videos that did not have 29.97 framerate worked fine!
JT, Thank you for all the help!
0 Kudos
Highlighted
Level 19

Re: My Media - Your Music and Video on the Roku DVP

"rraheja" wrote:
SOLVED

Great!

"rraheja" wrote:
Interestingly with wired, even videos that did not have 29.97 framerate worked fine!

The issue with videos not encoded at 29.97 or 23.976 fps was that they will start to rebuffer after 30 to 45 minutes and as time went on past that they would just rebuffer more and more often until they wouldn't play anymore. Other than that, they would play fine, so short videos aren't really a problem. And, I'm not sure whether later firmware releases improved upon the problem, but 29.97 and 23.9767 are the only frame rates officially supported.

"rraheja" wrote:
JT, Thank you for all the help!

No problem!

-JT
0 Kudos
Highlighted

Re: My Media - Your Music and Video on the Roku DVP

"renojim" wrote:
herbertbrubaker, what version of the firmware is on your box? It's under "Settings", "Player Info".

-JT


I'm currently at 1509.
0 Kudos
Highlighted

Re: My Media - Your Music and Video on the Roku DVP

"herbertbrubaker" wrote:
"renojim" wrote:
herbertbrubaker, what version of the firmware is on your box? It's under "Settings", "Player Info".

-JT


I'm currently at 1509.



Dumb question: How are people getting updates with builds higher than 1509? I am using the "check for update" option on the Settings->Player Info screen and it's not offering anything else. How would I get 1529?
0 Kudos
Highlighted

Re: My Media - Your Music and Video on the Roku DVP

"herbertbrubaker" wrote:
"herbertbrubaker" wrote:
"renojim" wrote:
herbertbrubaker, what version of the firmware is on your box? It's under "Settings", "Player Info".

-JT


I'm currently at 1509.



Dumb question: How are people getting updates with builds higher than 1509? I am using the "check for update" option on the Settings->Player Info screen and it's not offering anything else. How would I get 1529?

I mean 1521. D'oh.
0 Kudos