Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
renojim
Community Streaming Expert

Re: My Media - Your Music and Video on the Roku DVP

rraheja, I have to suspect a problem with your server, firewall, or router. Bit rates of 3000 kbps shouldn't be a problem. I use the command line version of HandBrake and basically use the default values except that I add the -O (web optimized) option and I force the framerate to 29.97 fps. I also set the output file size to be about the same as the input file size, thereby pretty much copying the bit rate of the source file. Do you have a problem video you could post somewhere that I could try?

As for the strangeness of one video seemingly affecting another, I've seen all sorts of strange things occur that only a reboot of the box will fix (and sometimes not even that will fix the problem).

-JT
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Miskaren1
Level 7

Re: My Media - Your Music and Video on the Roku DVP

I just got my Roku last week and absolutely love the MyMedia channel. It was working perfectly until yesterday around 5pm. Now the website to register, rokumm.appspot.com is loading an over quota message. Is this just affecting me or everyone trying to register?

Thanks!
0 Kudos
jlandis
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"Miskaren1" wrote:
I just got my Roku last week and absolutely love the MyMedia channel. It was working perfectly until yesterday around 5pm. Now the website to register, rokumm.appspot.com is loading an over quota message. Is this just affecting me or everyone trying to register?

Thanks!


I believe that it is affecting everyone. I spent the day yesterday working on getting it set up on one server and everything was working fine. But then in the afternoon I tried to set up the server on a different machine and the rokumm.appspot.com was giving a 503 over quota error.
0 Kudos
Miskaren1
Level 7

Re: My Media - Your Music and Video on the Roku DVP

Aww shucks, thanks for the info.

Maybe I'll just have to convince myself to get the XDS also. Smiley Wink
0 Kudos
dgrace
Level 12

Re: My Media - Your Music and Video on the Roku DVP

"dgrace" wrote:
Well, after everything I did yesterday, ending up with all working again, but today back to NO ALBUM ART. All of the mp3 files have embedded art, along with a jpg for artist in the artist folder (which does display). Any idea why embedded cover art shows up one day and not the next?

Bump
Any one else not getting embedded album art with the MyMedia channel? I'm wanting to find out if it's something here or in the build. Is there a specific ID3 protocol that needs to be adhered to? Having added art to over 600 mp3 albums took sometime, and it did work that first day, but now only artist art on top folder (which has the artist.jpg in it) but individual albums lack the album art except on each single track.
Looks like we all overwhelmed the google app......
"I might be moving to Montana soon..."
FZ
0 Kudos
renojim
Community Streaming Expert

Re: My Media - Your Music and Video on the Roku DVP

I think I misunderstood you before. What you're saying is you get the embedded album art to show up on individual tracks, but there's no album art displayed on the folder for the album when you're browsing, right? I can't imagine why it would work one day, but not the next. Let me look into it. Most, if not all, of my album folders have a JPEG in them, so I'll have to do some searching to find one with embedded album art but no JPEG.

-JT
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
rraheja
Level 7

Re: My Media - Your Music and Video on the Roku DVP

Thanks JT - I am going to try one of the videos with just framerate of 29.97 and see if it works fine after a reboot. If it doesn't I will try to upload a copy somewhere for debugging. My router is a Linksys E2000 and both the server and Roku are connected to it, so not sure if it would be a router issue. Photos and Music plays fine, so hoping that it is not a Windows Vista firewall issue either. So is there any latest/nightly builds of the server I can download? I simply went to the site referred in the private channel description and downloaded this a couple of weeks ago.

Also, is it ok to enable the DeTelecine or DeComb or DeInterlacing features or can those cause issues? Without it my old home videos have severe interlacing artifacts.

One additional issue I noticed is that when using one of the preset profiles, HB put two audio tracks - one 5.1 and a 2ch. Roku would not play any sound with those. When I remove the second track (and leave any one track) it plays fine. Is this a known issue - I saw a posting in the Developer forum; and since AppleTV requires the second channel if you want AC3 output, it would be a shame to convert all videos twice - one for Roku and another for ATV.

Thanks
Rajesh

"renojim" wrote:
rraheja, I have to suspect a problem with your server, firewall, or router. Bit rates of 3000 kbps shouldn't be a problem. I use the command line version of HandBrake and basically use the default values except that I add the -O (web optimized) option and I force the framerate to 29.97 fps. I also set the output file size to be about the same as the input file size, thereby pretty much copying the bit rate of the source file. Do you have a problem video you could post somewhere that I could try?

As for the strangeness of one video seemingly affecting another, I've seen all sorts of strange things occur that only a reboot of the box will fix (and sometimes not even that will fix the problem).

-JT
0 Kudos
renojim
Community Streaming Expert

Re: My Media - Your Music and Video on the Roku DVP

"rraheja" wrote:
Thanks JT - I am going to try one of the videos with just framerate of 29.97 and see if it works fine after a reboot. If it doesn't I will try to upload a copy somewhere for debugging. My router is a Linksys E2000 and both the server and Roku are connected to it, so not sure if it would be a router issue. Photos and Music plays fine, so hoping that it is not a Windows Vista firewall issue either.

Keep us posted.

"rraheja" wrote:
So is there any latest/nightly builds of the server I can download? I simply went to the site referred in the private channel description and downloaded this a couple of weeks ago.

el.wubo handles all the github stuff. I send updates to him and then he integrates them. He must be busy or we would have heard from him.

"rraheja" wrote:
Also, is it ok to enable the DeTelecine or DeComb or DeInterlacing features or can those cause issues? Without it my old home videos have severe interlacing artifacts.

I don't know, but I'll do some experimenting myself and see what happens.

"rraheja" wrote:
One additional issue I noticed is that when using one of the preset profiles, HB put two audio tracks - one 5.1 and a 2ch. Roku would not play any sound with those. When I remove the second track (and leave any one track) it plays fine. Is this a known issue - I saw a posting in the Developer forum; and since AppleTV requires the second channel if you want AC3 output, it would be a shame to convert all videos twice - one for Roku and another for ATV.

It's a known Roku issue. I thought the latest firmware removed the restriction, but maybe not. If not, I would expect multiple audio tracks to be allowed in the near future. I'll have to go back over the thread in the developer's forum.

-JT
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
renojim
Community Streaming Expert

Re: My Media - Your Music and Video on the Roku DVP

"dgrace" wrote:
Any one else not getting embedded album art with the MyMedia channel? I'm wanting to find out if it's something here or in the build. Is there a specific ID3 protocol that needs to be adhered to? Having added art to over 600 mp3 albums took sometime, and it did work that first day, but now only artist art on top folder (which has the artist.jpg in it) but individual albums lack the album art except on each single track.

I may be onto something. You were trying different server versions, weren't you? Looking back, there was a version that didn't handle embedded album art for the folder image, but that was a while ago and at that time I'm pretty sure the server that was launched was 'rss_server.py'. You aren't launching that, are you?

-JT
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
euphonek
Level 7

Re: My Media - Your Music and Video on the Roku DVP

Awesome job to everyone who's contributed to this, it's so great to have this capability now! It really does show what the Roku is capable of and hopefully they'll enable native support for it someday...

Anyhow, I'm working on a script that handles the conversion and management of my video files. Currently I'm just writing it in windows batch because that's what I'm most familiar with, but I might look at rewriting it in Python (haven't used Python before so I didn't want the learning curve to slow me down right now).

I'm pretty well on my way with conversion part, but I was also thinking it would be cool if my script could also manage watched/unwatched categories for me so that I can open a folder and only see my unwatched videos (and only directories that contain any videos). For instance, I could have 2 top-level directories "Watched" and "Unwatched" and whenever I finish watching something it will move the file into the "Watched" directory.

The only issue I'm having is that I haven't figured out where the "watched" information is stored (I know it's tracked somewhere because of the "watched on this date" message under the video). As I mentioned, I haven't used Python before, so digging through the code to find this hasn't yielded much yet for me...I really should get around to learning it I guess... Smiley Happy

Can anyone point me in the direction of how/where this is stored? Thanks!
0 Kudos