Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

I've tried installing mymedia and apparently I'm missing something.
Installed Python2.6, PIL and the server application.

when I launch mymedia I get the following:

C:\mymedia\server>c:\python26\python.exe mymedia.py
submitting 'http://192.168.1.xxx:8001' to rendezvous server as xxxx
http://0.0.0.0:8001/

x is used for generic purposes.

I can see the server using other computers. MyMedia channel looks to be configured correctly; however I get the following:
"Failed to autoconfigure server. You're on your own"
"Contact with server has not been established. Check your settings and that the server is running."

Any thoughts? I turned off my firewall on the server computer.

Thanks.
0 Kudos
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"eric_s" wrote:
I've tried installing mymedia and apparently I'm missing something.
Installed Python2.6, PIL and the server application.

when I launch mymedia I get the following:

C:\mymedia\server>c:\python26\python.exe mymedia.py
submitting 'http://192.168.1.xxx:8001' to rendezvous server as xxxx
http://0.0.0.0:8001/
x is used for generic purposes.

I can see the server using other computers. MyMedia channel looks to be configured correctly; however I get the following:
"Failed to autoconfigure server. You're on your own"
"Contact with server has not been established. Check your settings and that the server is running."



What operating system?

Any thoughts? I turned off my firewall on the server computer.

Thanks.
Going where the wind don't blow so strange
0 Kudos
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"dellsweig" wrote:
"eric_s" wrote:
I've tried installing mymedia and apparently I'm missing something.
Installed Python2.6, PIL and the server application.

when I launch mymedia I get the following:

C:\mymedia\server>c:\python26\python.exe mymedia.py
submitting 'http://192.168.1.xxx:8001' to rendezvous server as xxxx
http://0.0.0.0:8001/
x is used for generic purposes.

I can see the server using other computers. MyMedia channel looks to be configured correctly; however I get the following:
"Failed to autoconfigure server. You're on your own"
"Contact with server has not been established. Check your settings and that the server is running."



What operating system?

Any thoughts? I turned off my firewall on the server computer.

Thanks.


Running Windows7 on my computer. In a few minutes, I'll try to get it setup on a WinXP machine just to see if that makes a difference.
0 Kudos
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"eric_s" wrote:
"dellsweig" wrote:
"eric_s" wrote:
I've tried installing mymedia and apparently I'm missing something.
Installed Python2.6, PIL and the server application.

when I launch mymedia I get the following:

C:\mymedia\server>c:\python26\python.exe mymedia.py
submitting 'http://192.168.1.xxx:8001' to rendezvous server as xxxx
http://0.0.0.0:8001/
x is used for generic purposes.

I can see the server using other computers. MyMedia channel looks to be configured correctly; however I get the following:
"Failed to autoconfigure server. You're on your own"
"Contact with server has not been established. Check your settings and that the server is running."



What operating system?

Any thoughts? I turned off my firewall on the server computer.

Thanks.


Running Windows7 on my computer. In a few minutes, I'll try to get it setup on a WinXP machine just to see if that makes a difference.


OK. So I switched it to an XP machine and all works fine. Has anyone had any luck using Windows 7?

Thanks!
0 Kudos
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"eric_s" wrote:

OK. So I switched it to an XP machine and all works fine. Has anyone had any luck using Windows 7?

Thanks!


Quite a few people are using it with windows 7. I believe some have had issues with the windows firewall settings that come with windows 7 preventing the Roku from connecting to the server. Try searching this forum for win7 or windows 7.
0 Kudos
Highlighted
Level 8

Re: My Media - Your Music and Video on the Roku DVP

"el.wubo" wrote:
...Try searching this forum for win7 or windows 7.
A search for win7 will work but a search for windows 7 or even "windows 7" will not as it returns the info that "windows 7" is too common a term.

But the search for win7 seems to return a large number of results that may contain the needed information needed.
0 Kudos
Highlighted
Level 7

Re: My Media - Your Music and Video on the Roku DVP

"Gilgamesh" wrote:
"el.wubo" wrote:
...Try searching this forum for win7 or windows 7.
A search for win7 will work but a search for windows 7 or even "windows 7" will not as it returns the info that "windows 7" is too common a term.

But the search for win7 seems to return a large number of results that may contain the needed information needed.



The sequence of troubleshooting in the forum may be of some use to you. It starts here: viewtopic.php?f=28&t=25955&p=224360&hilit=firewall#p224360
0 Kudos
Highlighted
Anonymous
Not applicable

Re: My Media - Your Music and Video on the Roku DVP

So installed everything, and mymedia runs and finds my files. When I go to start a video, I get the "retrieving..." bar at the bottom of the screen, and "quality" shows four dots. It hangs here forever.

I searched the forum, and found a similar problem from drum365, but no solution.

I have tried my own files, as well as some ray charles video that a user posted here to use a "good" trial file. Nothing plays.

Ideas?
0 Kudos
Highlighted
Level 19

Re: My Media - Your Music and Video on the Roku DVP

Have you tried any music files?

-JT
0 Kudos
Highlighted
Anonymous
Not applicable

Re: My Media - Your Music and Video on the Roku DVP

I just checked, and yes, music works. Video still hangs at "retrieving", with the bar indicating about 90% done. I have restarted the roku box and the server, with no effect.

FYI, Here are my server settings as indicated when i run "springboard.vbs":

video_dir: E:\DVD Rips
collapse_collections:False
server_port_8001
roku_ip:192.168.1.6 (should this be anything in particular? at first it was the same as my server IP, I manually changed it to .6.)
max_folders..:10
python_path:c:\pyhon26....
server_ip:192.168.1.5 (i check usings ip config at dos prompt, this is correct)
0 Kudos