Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
uarlive
Level 7

Issue with development mode

I noticed today when I attempt to generate a new key on my roku 2 and roku 3 devices the telnet prompt exits abruptly. All I did was press enter to type in the genkey command. Both devices are using the latest firmware 7. Any help is appreciated. Thanks.

telnet 192.168.0.12 8080
Trying 192.168.0.12...
Connected to 192.168.0.12.
Escape character is '^]'.

Connection closed by foreign host.
0 Kudos
6 Replies
sio
Level 7

Re: Issue with development mode

This happened the other day to me and a simple power cycle resolved the issue. Did you try that first?
0 Kudos
uarlive
Level 7

Re: Issue with development mode

Yes I did. Im going to try a factory reset as a last resort. Thanks!
0 Kudos
EnTerr
Level 8

Re: Issue with development mode

that happens on what firmware version and model number ("roku 2" means many, many things)?
might be relevant.
0 Kudos
uarlive
Level 7

Re: Issue with development mode

EnTerr. I figured out the issue. The Mac i was working on was blocking port 8080. I used another Mac and it worked fine. Thanks!
0 Kudos
EnTerr
Level 8

Re: Issue with development mode

"uarlive" wrote:
EnTerr. I figured out the issue. The Mac i was working on was blocking port 8080. I used another Mac and it worked fine. Thanks!

Cisco AnyConnect?
viewtopic.php?f=34&t=63030&start=15#p514797
0 Kudos
uarlive
Level 7

Re: Issue with development mode

Yes I did recently install cisco anyconnect. Ill kill that and see what happens. Thanks!
0 Kudos