Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
24i
Level 7

(Feature request) default subtitle and audio SG Video

Hi all,

Let me first explain the problem, as there may be a solution for this already.
We are creating a custom audio and subtitle selection overlay for our video's. We encountered the following:
According to the docs (which seems to be right as we tested this) there is a "audioTrack" and "subtitleTrack", but by default they are set to an empty string. We hoped that if a hls stream had default subtitle setting the 'subtitleTrack' would be adjusted to this, but unfortunately this is not the case. 
For the custom selection screen we want to put an indicator before the current playing audio and subtitle track, but as these aren't set by the Videoplayer upon start we can't look this is up anywhere. 
The default Roku popup for selecting an audio and/or subtitle does show the current audio or subtitle, so somehow it can be done.

Can anyone help us out with this?
Or should this be a feature request to let the Videoplayer set the "audioTrack" and "subtitleTrack" upon playing for the first time?

Thanks!
0 Kudos
4 Replies
24i
Level 7

Re: (Feature request) default subtitle and audio SG Video

Bump.

Anyone has any ideas about this? 
0 Kudos
Roku Employee
Roku Employee

Re: (Feature request) default subtitle and audio SG Video

What is the reason to want to avoid the default handling of this with the "*" popup menu? 
Diverging in the player UX doesn't seems like a good idea.
0 Kudos
24i
Level 7

Re: (Feature request) default subtitle and audio SG Video

Well the main reason is that we create custom video UI, as that is requested by our clients. And because of that we don't set the focus to the Video node, thus the '*' will not trigger the popup.
0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: (Feature request) default subtitle and audio SG Video

"24i" wrote:
Well the main reason is that we create custom video UI, as that is requested by our clients. And because of that we don't set the focus to the Video node, thus the '*' will not trigger the popup.

You could ostensibly let it "trickle down". I.e. set the input focus to a node that's under Video in the hierarchy, then when handling buttons recognize "*" and do not handle it (i.e. return False in the handler), so that the Video can pick it up
0 Kudos