Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8

Re: Eclipse plugin for Brightscript

"brocker" wrote:
No one is having the same issue?? I'm having it on three machines, so can't be just me can it?

The selected wizard could not be started.
Plug-in com.domhain.brightscript.plugin was unable to load class com.domhain.brightscript.plugin.wizards.newproject.BrightScriptProjectWizard.
An error occurred while automatically activating bundle com.domhain.brightscript.plugin (228).


Anyone have ANY idea who to contact about this? I'd really love to have this back, trying to work with BrightScript is kinda like caveman coding without some of the benefits of this plug in.

Thanks!
Bud
Brocker,
You may have missed malloys' reply to you:
viewtopic.php?f=34&t=31199&view=unread#p263009
"malloys" wrote:
"brocker" wrote:
Hi All,

I'm suddenly getting the following error in Eclipse (was working on Friday 4/29) when trying to create a new BrightScript project:

The selected wizard could not be started.
Plug-in com.domhain.brightscript.plugin was unable to load class com.domhain.brightscript.plugin.wizards.newproject.BrightScriptProjectWizard.
An error occurred while automatically activating bundle com.domhain.brightscript.plugin (228).


I saw someone else had this issue and resolved it by uninstalling and installing, but that did not work for me. Is there any kind of resolution to this??

Tech Details:
OS: Windows 7 (also broke on Mac 10.6.7)
Eclipse Version: 1.0.0.201101111145
Java Version: 1.6.0__25


Thanks
Bud



The plugin was in beta, and timed-out on 5/1 - that's what you're seeing.
The plugin source code is now officially owned by Roku, and I am working with them to get a new version out as soon as possible... stay tuned.

Cheers
Remoku.tv - A free web app for Roku Remote Control!
Want to control your Roku from nearly any phone, computer or tablet? Get started at http://help.remoku.tv
by Apps4TV - Applications for television and beyond: http://www.apps4tv.com
0 Kudos
Highlighted
Level 8

Re: Eclipse plugin for Brightscript

Shoot, thanks. I did not see this reply. Hopefully Roku gets their game together ASAP! I jumped over to Visual Studio, but it's not as nice as the Eclipse plugin.

Thanks!!
Bud
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

@Brocker: We all have the same issue. The plugin was a time-limited beta and the time ran out on May 1st.

I keep asking for the original plugin to be re-released with an updated time limit to tide us over until the formal Roku plugin is available, but since there's been no response I assume there's something wrong with that idea.
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

"migmigmig" wrote:
@Brocker: We all have the same issue. The plugin was a time-limited beta and the time ran out on May 1st.

I keep asking for the original plugin to be re-released with an updated time limit to tide us over until the formal Roku plugin is available, but since there's been no response I assume there's something wrong with that idea.


Nothing wrong with the idea... just needed to communicate the options with the Roku folks and get a decision... which is now done.
I should have an updated time-limited plugin posted later today.

Cheers
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

Sweetastic.
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

As requested...

A new version of the beta plugin has been posted.
This is exactly the same as the old beta plugin, just with a new time-out of 7/4/11.
All prior statements of functionality and platform support/testing still stand.
The plugin update site is still: http://www.domhain.com/eclipse/updates

Cheers
0 Kudos
Highlighted
Level 8

Re: Eclipse plugin for Brightscript

Awesome!! So with this change, you can't create a new BrightScript project, but you can open a previous one and have the formatting? Just making sure I installed correctly (I no longer see an option to create a new project).

Thanks!
Bud
0 Kudos
Highlighted
Level 8

Re: Eclipse plugin for Brightscript

"malloys" wrote:
As requested...

A new version of the beta plugin has been posted.
This is exactly the same as the old beta plugin, just with a new time-out of 7/4/11.
All prior statements of functionality and platform support/testing still stand.
The plugin update site is still: http://www.domhain.com/eclipse/updates

Cheers

thats why I was mad. you seemed to be saying you couldn't release one with a new timeout.
if you are going to continue to allow the community to keep using the plugin then I cant say anything bad about you.
And I personally thank you for re releasing this plugin.
I am going to delete my previous post about this.
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

"brocker" wrote:
Awesome!! So with this change, you can't create a new BrightScript project, but you can open a previous one and have the formatting? Just making sure I installed correctly (I no longer see an option to create a new project).

Thanks!
Bud


You should still be able to create new projects, since that code was not touched.

The new project wizard is under:

File->New->Project
This opens up the standard eclipse "New Project Wizard".

Then, both at the top and also under the BrightScript folder, you should see the "BrightScript Project" menu item, which when selected should open up the "New BrightScript Project" wizard dialog.
(I've verified that this is still the case under both 3.5.2 and 3.6.1 on Windows 7 - on other platforms, YMMV).

Cheers
0 Kudos
Highlighted
Level 8

Re: Eclipse plugin for Brightscript

Yeah, that's where I was expecting to see the package, but it's now missing. I noticed that during the re-install, only the package "Basic BrightScript Support" shows up in "Installed Software" of Eclipse. Before there were two packages that installed, the second one called "Advanced BrightScript Support".

I tried uninstalling and reinstalling full, but the second package never gets installed. I only see the "Basic" package, and am unable to create new packages, but Eclipse recognizes the BrightScript syntax however which is great.

Would be nice to be able to create new packages, but small steps I guess!

Thanks
Bud
0 Kudos