Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Heyitsrick
Level 12

Re: Update 9.2 broke dolby digital

Jump to solution

@SmilingBob wrote:

sgmfish, that is all outstanding information and I'm sure it will help some folks.  Unfortunately, much of what you posted does not apply to many of us.  My 5.1 surround works perfectly in all apps on my Roku, except for Netflix.  No idea why, but I'm not the only one.  Hopefully there is more information or an app/firmware update that automagically fixes it for the rest of us.

 


The fact that you're only missing surround on Netflix suggests it is not a Roku problem, but rather some kind of app issue or a settings issue.  Specifically if you're getting surround sound from Amazon - which uses the same Dolby format as Netflix - then obviously you don't have a global surround issue.  I'd be looking at the app or your settings.

0 Kudos
SmilingBob
Level 9

Re: Update 9.2 broke dolby digital

Jump to solution

@Heyitsrickyou are spot on, my Amazon Video works perfectly and Netflix does not.  I am the perfect control specimen since I've changed absolutely nothing.  One day it was working, next day it was not. Most people stated they noticed the issue with 9.2 firmware but it very well could be a Netflix app issue, as I've previously stated.  The Netflix app on our TV works fine in 5.1 so I can always use that if I want, it is still a Roku issue since it does not work on the Roku for many of us. 

Roku does not write the apps, I get that, but the platform seems to be falling behind in audio.  My Sling TV app is 5.1 on the Samsung TV app, only stereo using the Rokus (I have 5 Rokus, all the same).  Now Netflix.  Doesn't breed much confidence and I've spent way more time trying to troubleshoot this than I should.  I'll personally just live with it until which time I decide to update my devices to a different platform.

0 Kudos
sgmfish
Level 10

Re: Update 9.2 broke dolby digital

Jump to solution

One possible way Prime works but Netflix doesn't is if one's internet speed is slow. I read somewhere that Netflix dynamically changes the audio it is streaming to a user from 5.1 to stereo if it detects that the connection speed drops below a certain level. Netflix has always been aware of connection speed and modifies the streaming accordingly, but apparently they are now adjusting audio, either degrading or upgrading it, on a second by second basis. YMMV

0 Kudos
SmilingBob
Level 9

Re: Update 9.2 broke dolby digital

Jump to solution

Solved - quick update and full disclosure:  I was wrong, it was a Netflix account setting that was limiting the audio for us.  At some point (this ski vacation) the playback settings for "Data usage per screen" got lowered.  I could not find much information on how the audio gets affected for each setting (Auto, Low, Medium, High) but apparently lowering the quality of the video also lowers the quality of the audio.  This makes sense, as Dolby Digital 5.1 & DD+ is going to use more bandwidth than stereo.  Ticked it back to "High" and Lo and Behold, 5.1 audio is back.

I kept at this because it made no sense to me that every other app that normally worked in 5.1 still worked fine and my OCD wouldn't let me quit troubleshooting (it's a curse).  Thanks to all who helped and I retract my statement about Roku audio issues, as it's not Roku's fault when someone is all eat up with the Dumass.

View solution in original post

Heyitsrick
Level 12

Re: Update 9.2 broke dolby digital

Jump to solution

@SmilingBob wrote:

Solved - quick update and full disclosure:  I was wrong, it was a Netflix account setting that was limiting the audio for us.  At some point (this ski vacation) the playback settings for "Data usage per screen" got lowered.  I could not find much information on how the audio gets affected for each setting (Auto, Low, Medium, High) but apparently lowering the quality of the video also lowers the quality of the audio.  This makes sense, as Dolby Digital 5.1 & DD+ is going to use more bandwidth than stereo.  Ticked it back to "High" and Lo and Behold, 5.1 audio is back.

I kept at this because it made no sense to me that every other app that normally worked in 5.1 still worked fine and my OCD wouldn't let me quit troubleshooting (it's a curse).  Thanks to all who helped and I retract my statement about Roku audio issues, as it's not Roku's fault when someone is all eat up with the Dumass.


No worries - and thanks for providing the info on the "fix". That's the most important part of trouble threads, where the original poster never chimes back in. Happy streaming!

0 Kudos
IDW
Level 8

Re: Update 9.2 broke dolby digital

Jump to solution

Hi 

I know that this thread is solved but I have exactly the same setup as @Zwack (Sony TV DD capable with ARC to Soundbar DD+ capable) - I am only getting stereo PCM appearing at the sound-bar when connecting the box to the TV.

I am in UK and am using a 'NowTV 4K box' - a branded Roku 

This all started with shocking sound on Westworld s3 - realised I was hearing an auto-downmix which appeared to remove the dialog - having replugged blu-ray I managed to get DD+ but would prefer via TV

@Zwack did you come up with a solution?

Thanks

0 Kudos
Zwack
Level 7

Re: Update 9.2 broke dolby digital

Jump to solution

@IDW Forcing my Roku to Dolby Digital Plus/DTS worked for a while, but then stopped working when there was an upgrade to the sound bar firmware. 🙄

This seems to be particularly an issue with Netflix as most other services work.

I have not found a permanent fix unfortunately.

0 Kudos
IDW
Level 8

Re: Update 9.2 broke dolby digital

Jump to solution

@Zwack Thanks for the reply - a pity there isn't a solution (apart from a new TV and sound-bar with eARC...) - I tried forcing to DD+/DTS but was silent, I guess the TV just ignored it.

I hadn't realised the Roku just passes on the received format, I thought it would drop DD+ to DD...

I also have an Apple TV which transcodes (guess you get what you pay for) so Netflix, Amazon Prime, Disney+ etc.. get to the sound-bar in DD. Unfortunately Sky TV (have distribution of most of HBO etc in UK) have a prehistoric NowTV streaming App on Apple TV (720i and "stereo") so I needed to get their branded Roku (on offer with subscription) to get at the 1080p 5.1 stream I'm paying for..

Ian

0 Kudos
Zwack
Level 7

Re: Update 9.2 broke dolby digital

Jump to solution

Unfortunately apart from one (discontinued) Roku model it doesn't do format conversion.

I don't know of any HDMI box that just does Dolby Digital Plus to Dolby Digital conversion.  

 

 

0 Kudos
plinn777
Level 7

Re: Update 9.2 broke dolby digital

Jump to solution

@sgmfish wrote:

@RokuTannerD wrote:

Your device does not downgrade audio formats on its own, however, it may select an alternate audio format that is available if a user's setup does not support Dolby Digital+, such as a receiver that is only capable of playing standard Dolby Digital.

 

TannerD,

This is just not strictly true. I've come to the belief that much of these user problems are the very confusing options in the Roku settings; in particular, the 2 setting areas under "System|Audio". For example, my main problem was that I had the "Audio|HDMI" setting set to "Digital Dolby, DTS"; when you do that Dolby Plus will NOT be passed thru to your AVR. My AVR is quite recent and decodes every possible protocol including DTS, old Dolby, and Dolby+; so your statement above is incorrect in that setup.

Here's the detailed explanation: let's say my channel is Netflix; note Netflix's 5.1 sound is Dolby+; but I have the "Audio|HDMI" setting set to "Digital Dolby, DTS"; also given that my AVR is definitely capable of Dolby+; none the less all I get out of the speakers is stereo. Now, if I change the "Audio|HDMI" setting to "Auto Detect", I do get the Netflix Dolby+ 5.1 sound from my speakers.

So at least one of the problems here is the confusing nature of Roku's "Audio" settings.....especially the "Audio|HDMI" setting. That setting gives you 3 choices: "Auto Detect", "Digital Dolby, DTS", or "Dolby Plus, DTS". Note there are 3 possible audio formats here: Digital Dolby, DTS, and Dolby Plus, but if you pick any option other than "Auto Detect" you will not get 5.1 sound (but only stereo) from a channel that uses the missing format even though your AVR supports that format. At the very least, the "Audio|HDMI" setting should offer a "Digital Dolby, DTS, Dolby Plus" option since without knowing ahead of time that Roku's "Auto Detect" option is required in order to use all 3 formats, and you decide to pick one of the other 2 options, you can only get 2 of the 3 possible formats regardless of what you do (IOW, each of these other 2 options eliminates either Dolby+ or old Dolby).


 


Man..... Thank You sooooo much for that. That's exactly the problem. 

I'm reading all kinds of Roku AV support set up this and that. And was ready to buy an HDMI to Optical converter thinking it just had to be something in the Roku itself. Despite reading all the stuff about it being pass through. The audio setting I picked was directly from Roku support and it was wrong. 

And I knew something was up, because my old Denon reciever only gets DTS/ Dolby Digital to output 5.1. I had to double check the audio settings in my Sony Bravia 4k TV to make sure it was pass through also. 

So it was HDMI to TV optical out from TV to receiver. And the Roku support settings for audio. Didn't work. Even though I knew what I had set everywhere else was correct. I would get 5.1 on Netflix from the TV itself, but not from the Netflix on the Roku. Only either stereo or Pro Logic II.

The cable box was also the same, HDMI to TV and again, optical to receiver and it was giving me Doby Digital 5.1, same as the Smart TV Netflix. 

So I was convinced it had to be the Roku. And was going to get a converter.

All I had to do was select Auto Detect and finally.... Dolby Digital 5.1 from the Roku.

0 Kudos