Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
curtpair
Newbie

Why is Guest Mode Not working? Needs to re-connect to network

I have several Roku devices...

When trying to use my Roku Stick... I can't seem to get "Guest Mode" to work.  I 'sign out' of my 'normal' account... the Roku reboots... then says it needs to connect to the network... I select the wireless network, the same network it uses when in normal mode, with the same SSID and password...  The Roku stick then accepts the settings and all appears great; it appears to have found the network...

Then the screen goes back to guest sign in... and it hangs up!   It appears that the 'circle' graphic is hung up on the right side of the screen... all I can do is select the " * " key and reconnect to the network... I end up in a cycle of doing this over and over again.

Any ideas out there?

Thanks in advance! 

11 REPLIES 11
Jenhood446
Newbie

Re: Guest Mode Not working

I’m having the same issue. I enable guest mode and then sign out on desired date and network connection disconnects. I have to reconnect to WiFi and then sign out. And then go in to the main account and renter the  WiFi info to reconnect again! 

using Onn Roku TV

0 Kudos
RokuDanny-R
Retired Moderator

Re: Guest Mode Not working

Hi everyone,

Thanks for the posts.

We would recommend taking a look at the steps provided by our Support page here: How do I set up Guest Mode on my Roku® streaming device?

If you are still experiencing an issue, please provide the steps to reproduce the issue and we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Community Moderator
0 Kudos
Martie
Reel Rookie

Re: Guest Mode Not working

I have the exact same problem!!!! Unable to watch my Roku tv! Someone please help!!! The roku chat agent couldn't help me and sent me back to their same site. Never had a problem with roku.

0 Kudos
RokuDanny-R
Retired Moderator

Re: Guest Mode Not working

@Martie

Thanks for the post.

Can you please specify the issue you are experiencing? What are you seeing and what are the steps to reproduce the issue?

With more detailed information, we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Community Moderator
0 Kudos
Jdcarms
Newbie

Re: Guest Mode Not working

In regular mode I connect to Wi-Fi. I then turn on guest mode and am asked to connect to the internet. I sign in to the same Wi-Fi network as the regular mode. I sign out as a guest, keeping it in guest mode. guest mode. I sign in as a “new guest” and again it says I’m not connected to the internet. Do I need to reconnect with each guest login?

RokuDanny-R
Retired Moderator

Re: Guest Mode Not working

@Jdcarms

Thanks for the post.

We would recommend taking a look at the information provided by our Support page here: Let visitors sign into your Roku with Guest Mode

If you are still unable to resolve the issue you are experiencing, can you please provide the serial number of your Roku device from Settings>System>About? I'll be able to assist you further from there.

 

Thanks,
Danny

Danny R.
Roku Community Moderator
pdxjenny
Newbie

Re: Guest Mode Not working

Danny from Roku, your reply is really annoying as it is not helpful to keep repeating the same support mantra that we need to review the guest mode instructions.  The answer to our problem is not found in that link.

Other users who have a Roku TV or Roku TV Wireless Soundbar should try using the advice found here for "Fast TV Start" - https://support.roku.com/article/360011064094 

All of us Roku users who provide the Roku Guest Mode to guests staying in our homes have read and re-read the instructions provided at https://support.roku.com/article/360015612834.  I have three Roku devices in my family vacation home and have this problem every time I switch the devices to guest mode so that other family members can use their own subscriptions.

The following steps are taken when I am finished using the Roku device for my own subscriptions (using wireless network.)
Steps to recreate:
1. Enable Guest Mode on Roku device
2. Device restarts and Guest Mode Welcome screen appears
3. User is prompted to click "Get Started"
4. This brings the user to the "Select your check out date" screen, which defaults to December 31, 1969.
PROBLEM: The calendar uses December 31, 1969 unless the Roku device immediately connected to the wireless internet ID.  The user cannot change the year, but can only scroll through 53 years of months to get to the current date.
5. One way that I have figured out how to restore the date to the current date is to press * to go to Settings and look for the wireless connection, click OK and then go back to the Get Started welcome page.  This is troublesome because it involves many further steps that the older members of my family have the most trouble with.  I am trying to make their viewing experience as easy as possible by offering Roku devices, but these additional steps are not easy or intuitive for elder or tech-challenged people.

Unfortunately, we are all experiencing the same issue regarding the Roku device not auto-connecting to the home's wireless network which then causes the Roku Guest Mode date to default to December 31, 1969.  I have tried waiting up to 2 minutes to see if the device would automatically find the network (as it should) but waiting didn't change the outcome.  It has nothing to do with signal strength or proximity to the router, so please don't try to school me on that.  This doesn't happen when the device is already logged into my account, so why is this a problem only with Guest Mode??  

Roku software fixes would repair this problem:
December 31, 1969 is the Linux epoch date in the western hemisphere.  For users with programming experience, you'll notice that this error is typical when the programmer does not store a date properly and the software "sees" a date of 0. Roku programmers should start there. 
OR at the very least, change the calendar/date selector so that the guest can select the YEAR as well as the month and day instead of making the guest scroll through all of the years.

Next month when we go the the vacation home to celebrate Easter together, I will try one last thing - a Fast Ethernet adapter. (See Roku support page  -  https://support.roku.com/article/360058027813)  Sadly, this can only be used with one of our devices as the other two are not located near an ethernet port.  At least for the main living room device, I am hoping this ethernet adapter will offer two benefits of reducing the bandwidth used on my wifi as well as offering a way for Guest Mode to work the way Roku intended without encountering the date from 1969.  

Re: Guest Mode Not working

@pdxjenny,

spot on! Having the same issue and am not seeing Roku provide a solution. We’re you able to find a solution?

#guestmode

0 Kudos
PPRentals
Channel Surfer

Re: Guest Mode Not working

This issue or at least one that is similar has been documented on the forums numerous times, and continues to be an issue that is now close to four years old.  Don't hold your breath waiting for any sort of actual support or engineering follow through. Guest mode seems to be an abandoned feature at this point.

0 Kudos