Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
AvsGunnar
Community Streaming Expert

Re: Sleep timer not available on streaming players?

Jump to solution

@Crissiek 

On Roku streaming players and Streaming Sticks, be sure to enable Bandwidth Saver. (Settings/Network/Bandwidth Saver/On) . This will stop all streaming and data usage automatically after four (4) hours of user inactivity.  This way you can set your TV sleep timer and know at least in 4 hrs your Roku will stop streaming.  

Otherwise, using various timers like the one shown by @Iona-D and other timers at outlet (programmable push button for 2hrs, 4hrs, etc) can also be used. (https://unclutterer.com/best-outlet-timer/).  A search on Amazon or Ebay will also give you a variety of options.

On RokuTVs, you can set your Sleep Timer and when the RokuTV powers down, streaming and data usage will automatically stop.  This is applicable only to RokuTVs. 

For Roku streaming players, you must either press the Home button on the Roku button to immediately stop streaming/data usage or at least enable Bandwidth Saver to minimize unnecessary data usage.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
mikem8
Newbie

Re: Sleep timer not available on streaming players?

Jump to solution

My sleep timer saying is not available on my TV it just disappeared out of nowhere no shortcut title or anything what the **bleep** happened

0 Kudos
RokuDanny-R
Retired Moderator

Re: Sleep timer not available on streaming players?

Jump to solution

@mikem8
Thanks for the post.

Can you please clarify the issue you are experiencing? Can you please provide us with the following information:
-Roku device model, serial number, device ID, and software OS/version (these can all be found in Settings > System > About)
-steps to reproduce the issue you are seeing 
-screenshot of the issue so we can better understand what is happening

With more detailed information, we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Community Moderator
0 Kudos
scott205
Streaming Star

Re: Sleep timer not available on streaming players?

Jump to solution

Bought ROKU to return spectrum cable box and save a few bucks. There are reasons I need to leave my tv on all day. ROKU is awesome.....but.....NO SLEEP timer and it goes off after 4 hours. SUCKS ROKU. ROKU employee wake up.....I already returned my cable box now I will have to get another one. Such an awesome device.....HIGHLY DIASPPOINTED

0 Kudos
scott205
Streaming Star

Re: Sleep timer not available on streaming players?

Jump to solution

Bought ROKU to return spectrum cable box and save a few bucks. There are reasons I need to leave my tv on all day. ROKU is awesome.....but.....NO SLEEP timer and it goes off after 4 hours. SUCKS ROKU. ROKU employee wake up.....I already returned my cable box now I will have to get another one. Such an awesome device.....HIGHLY DIASPPOINTED

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Sleep timer not available on streaming players?

Jump to solution

@scott205 

If you need a sleep timer for your Roku device, add an external smart plug or timer at your wall outlet and plug both your Roku device and TV into this timer or plug.  Then set the timer via a mobile app or manually and you have now equipped yourself with a sleep timer.

If you need the Roku device to continue streaming for longer than 4hrs, then try Disabling both Bandwidth Saver and Auto Power Saving (newer Roku devices) as well as Screensaver.  Note: even with these settings disabled, some channels/apps may still stop streaming after a certain number of hours and display their own screensaver (depending on the developer's choices).

Settings/Network/Bandwidth Saver/[Off]

Settings/System/Power/Auto Power Savings/20-min [uncheck to disable]

Settings/Theme/Screensaver Start Time/[Disable screensaver]

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

scott205
Streaming Star

Re: Sleep timer not available on streaming players?

Jump to solution

THX so much. I disabled the bandwidth saver and took power out of USB and plugged into an outlet w a new extension cord. So far today it has not went to sleep after 7.5 hours. I will try the other things you mentioned if I need to. THX FOR THE REPLY. ROKU should put on the box their is no sleep feature. I need my tv on longer during the day......even if I'm not home.

0 Kudos
scott205
Streaming Star

Re: Sleep timer not available on streaming players?

Jump to solution

I have Spectrum app and I had to go into that app and change the sleep default from 4hrs to 24hrs. I got the ROKU which indeed is very nice (4K+) over the cable box which I took back before I discovered no sleep timer. Thx to the forum and your help I don't have to go get another box and pay that fee!

jrw31
Newbie

Re: Sleep timer not available on streaming players?

Jump to solution

This year I purchased 9 Roku 4k sticks and I am disappointed sleep timer is not included.  I am not going to purchase 9 smart plugs to fix this Roku error.  I would like to see Roku send out an upgrade with sleep timers.  From the number of comments on this topic I am obviously not the only one missing this.

RokuLianna
Retired Moderator

Re: Sleep timer not available on streaming players?

Jump to solution

Hi @jrw31,

We appreciate your post.

Currently, the Sleep timer feature is available on Roku TV. Feel free to check on our blog at blog.roku.com for any future announcements or updates.

You may also share or suggest a feature request here: https://community.roku.com/t5/Suggest-a-Feature/bd-p/Wishlist.

Moreover, Starting Roku OS 10.5 has added a new Power item in Settings > System menu for some Roku models. If you have this Power item, under Auto power savings, see if deactivating after 20 minutes of no interaction fixes the problem


Warm Regards,
Lianna

 

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.