Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku Express 4K+ 3941x won't go past power up

My Roku Express 4k+ just stopped working. It was playing and then froze sat and waited to see if it would unfreeze it didn't I pressed the home button didn't do anything so I shut the Roku off left it off for a while and then powering it back on the dancing Roku came in the screen and will not go past that point I have unplugged it left it unplugged for a while pressed the reset button in the back and held it it took the dancing Roku off the screen when it came back on it was still the dancing Roku screen and it hasn't loaded in over a hour tried different TV's nothing. I have check the batteries they are new.. the internet connection is fine because the other Roku isn the house works..  

The model number is 3941x

No SD card insert it was completely up to date with software?? Please help...


0 Kudos
Community Streaming Expert

Re: Roku Express 4K+ 3941x won't go past power up


First try restarting both the Router, then the Roku device.  If no luck, again press and hold that reset button for 30+ seconds. Additionally, make sure you are powering the Roku device with the power adapter plugged into a wall, not your TV's power port.

If still no luck, likely you have a failed device.  If under a year, then should qualify for warranty replacement.

Step-by-step instructions for returns and warranty replacements - (https://support.roku.com/article/208757058)

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos

Re: Roku Express 4K+ 3941x won't go past power up

The underpowered Roku branded usb power supply is faulty. Notice the flickering power led. Interestingly, the boot up animation will play, but then goes dark. Just replace with another USB power supply. Preferably a more robust output of 2 amps (or greater). 


0 Kudos