MikeConn
Channel Surfer

Roku Speakers still not working

I posted almost 4 months ago, how my Roku speakers would not pair with my brand-new TCL tv.  Roku has been no help at all in trying to fix the problem.  They still will not pair, and I've tried everything.  I was hoping for the new version 13.0 software update would fix it, but nothing has changed, still will not pair.  Roku support gives you a song and dance to get you off the phone, then apparently, they just make up some story on how they are working on it and will call back in a few days???!!!  Sounds like some type of scam, so bottom line is I paid Roku for these speakers, they don't work, I don't get support and they are sitting on my floor like a couple of rocks.  I should have bought the Bose speakers; I guess if want speakers that is what I will have to do and let this be a lesson to not buy a Roku sound system again.

Labels (1)
0 Kudos
5 REPLIES 5
RokuJharra-Q
Community Moderator
Community Moderator

Re: Roku Speakers still not working

Thanks for keeping us posted, @MikeConn!

We understand you have difficulty connecting your Roku Streambar to your TCL Roku TV. We are here to help you set up your wireless speakers. Please let us know if you receive any error messages or have tried other troubleshooting steps. If you haven't tried it yet, we recommend you check our support article, which provides a guide on how to set up your Roku Streambar SE or Roku Streambar with a Roku TV system.

We look forward to hearing from you and looking closely into this issue.

Thanks,
Jharra

Jharra Q.
Roku Community Moderator
0 Kudos
MikeConn
Channel Surfer

Re: Roku Speakers still not working

Jharra,

As I wrote 4 months ago, and again recently, I have a Roku speaker connection problem.  I have both a Roku Streambar and Roku Subwoofer, they are working fine, just can't connect the speakers.  Thanks for reading my posts.  

I've been thru all the setup procedures, rebooting, etc.  They won't connect, so there is a bigger issue beyond the standard Roku Setup sheet.  Please don't tell me, like the woman I talked to from your Tech Support Dept., on a Friday night, that you are aware of the problem, and are working on it, and that you will call me in 24 hours, on the weekend.  Sounds like the old saying "don't call me I'll call you".

Again, these are Roku speakers, bought from Roku that never worked, but it's good to hear from someone after posting this originally 4 months ago. 

I'm really doubting Roku will fix this problem, after all this time, I'm not sure they are really trying to fix it.  Sounds like poor quality control and technical support, but I'll keep my fingers crossed for one last chance.

Thanks, so much.

0 Kudos
mrubano
Channel Surfer

Re: Roku Speakers still not working

The Roku speakers are connecting to the Streambar, not the TV.
I originally had issues setting up my speakers when I originally purchased them because I didn't read the complete setup instructions. I was pushing the wrong button on the back of the Roku Wireless Speakers, that is why they weren't pairing. Take a look and make sure you are pushing the reset first, and then the Pair button.
Also, If your TV has Roku embedded, I suggest choosing different themes on the Streambar, and TV so you are sure you are linking to the correct device.
But, I soon learned that when there are any changes to the speakers they must all be reset (not the streambar) and removed from the streambar, unplug the remote speakers, then reconnect.
I have the Roku® Streambar® Pro, and 2 sets of Roku Wireless Speakers setup on one TV and I Love it. It's alyways reliable, and sounds great but it was a little confusing during the original setup.
I have a TCL Roku TV, the streambar connected via HDMI to the TCL Roku TV via ARC port, and use the optical cable for audio (from TV to Streambar)...no issues once the figured out the learning curve.
Also, if you have a traditionakl cable box too, I found that the audio/lip sync worked better when the optical cable was connected to the TV and NOT the cable box. The cable box creates a small delay which messes up the lip sync.

0 Kudos
mrubano
Channel Surfer

Re: Roku Speakers still not working

Did you try resetting the sub first?
I would suggest that you reset the set of speakers, and reset the sub woofer, restart the TV and add the speakers. It should find them all.

0 Kudos
MikeConn
Channel Surfer

Re: Roku Speakers still not working

I appreciate the response mrubano.  I'm glad you were able to correct your issues.

Unfortunately, I tried all those steps and still the Roku speakers will not connect. 

I'm spending way too much time on this.  When I get the time and energy, I guess I will have to (again) call Tech Support, probably spend another hour or two on the phone, going over the same "how to steps" they repeat over and over again (just like my last call).  I wonder if they will tell me (again) that they will "give me a phone call over the weekend with the solution".  Sounds like the old saying "don't call me, I'll call you"

I don't know, maybe Sonos, Kplisch, Bose, Vizio, etc can fix the problem.

We will see.

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.