Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kp4akb
Level 8

Roku Express 4k+ 3941X when purchase had Ethernet MAC, after update 0.0.0.0.0

I purchased a Roku Express 4K+ and it worked fine with wired ethernet adapter. 2 days ago the wired option was deleted by Roku. 

Why take it away?

after updateafter update

0 Kudos
2 REPLIES 2
AvsGunnar
Community Streaming Expert

Re: Roku Express 4k+ 3941X when purchase had Ethernet MAC, after update 0.0.0.0.0

@kp4akb 

Roku didn't take the wired option from the Express 4k/4k+.  The MAC address of 00:00:00... just indicates that there is a loss of recognition of the MAC address from the ethernet adapter either at the Roku or at the router.  Without this recognition at the router, ethernet capability won't work.

Try unplugging the ethernet adapter and restarting both the router and the Roku device.  Then reinsert the ethernet adapter and see if you now have a MAC address.  Additionally, try unplugging/reinserting ethernet cable and perhaps trying another LAN port on the router.

If you still don't have a MAC address, try using the ethernet adapter on a laptop or your computer and see if this device sees it and recognizes a MAC address. (Often times, the adapter has its MAC printed on the adapter so you can compare these numbers).

Since this is an external ethernet adapter, could also be that it has simply failed.  If it is a software driver version capable ethernet adapter, see if you either spoof or assign it a new MAC address and then try again with the Roku and your other devices (laptop/computer).

It could be that the Roku 10.5 update caused an issue, but have to rule out the physical troubleshooting above first.

Feel free to post back with an update with the model number of the ethernet adapter.

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
kp4akb
Level 8

Re: Roku Express 4k+ 3941X when purchase had Ethernet MAC, after update 0.0.0.0.0

Thanks for the reply. I moved the Roku and its ethernet adapter to another location and it worked.

I say thanks for taking the time to help me and others in the Roku community

Ed Rios

Columbus, OH