Premium audio. Made simple.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 8

Re: ONN Soundbar 32 Voice Announcement

That’s definitely a work around but it doesn’t actually solve the power on/off announcement issue. What this does is prevent the soundbar from turning off with the TV, thus avoiding the announcement, however instead we get a blinking status light on the soundbar and an energy vampire when we’re not using it. 

0 Kudos
Level 8

Re: ONN Soundbar 32 Voice Announcement

Same issue here. Man are there a lot of wasted humans in this thread. Literally no one here trying to offer a solution has any idea what they’re talking about. 

I have a Hisense 65” Roku TV from Walmart. Via HDMI e-arc it’s connected to an Onn Roku-ready soundbar (blue box) also from Walmart. 

TCL soundbars do the same thing so it’s starting to look less and less like a soundbar issue… but just an observation. 

Screen Reader is disabled in the Roku system settings. 

When I turn the soundbar on (either with my Roku remote or it’s remote) it’s says very loudly, ‘Power On, HDMI’, and ‘Power Off’ when I turn it off. 

Again, not a screen reader. Nothing else is narrated. 

CEC setting for other devices is also disabled so when I turn off the TV the soundbar stays on. This is a nice workaround however what I get in exchange is a blinking status light on the soundbar when the TV is off, and it’s technically still on and wasting energy (which I pay for). Not an actual solution. 

Further comedy includes literally using my soundbar and then clicking the soundbar icon from the Roku Home Screen and the TV displays ‘No Signal’, are you sure it’s connected? LMFAO what a joke. 

Tags (1)
0 Kudos
Level 7

Re: ONN Soundbar 32 Voice Announcement

So I take it nobody figured out how to disable this feature on the onn sound bar?  It’s so loud and annoying.  And before anyone else comments, it’s the sound bar feature. I’m very aware it’s not the Roku or tv. Bout to toss this sound bar in the pool 

0 Kudos
Community Streaming Expert

Re: ONN Soundbar 32 Voice Announcement



Someone posted in another thread:


settings >control other devices>standby and uncheck to turn that feature off

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos