Discussions

Is your Roku TV not working? Join our online community forum to find help with common Roku TV issues, get troubleshooting tips, and share your experiences.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
descott12
Channel Surfer

No local antenna channels when connected to wifi

I have read all the posts that claim to fix this problem but they do not work.

My antenna channels only show in the Live TV screen if I am NOT connected to wifi. Otherwise, only streaming channels are shown.

As was mentioned in previous posts, NOWHERE are there menu choices for "Manage channels" or "Hide streaming channels". This is on TWO different ROKU smart TV's.

  • Settings > TV inputs > Live TV just has  Setup, Rename, or Remove
  • Home > Live TV just goes to a list of streaming channels.

What am I missing?

Also, I found nowhere to actually disconnect from wifi. That would would be a workaround but even that apparently cannot be done either. If I attempt to modify my wifi connection by clearing the password, it will not save the connection and I stay connected.

Thanks in advance.

0 Kudos
6 REPLIES 6
AvsGunnar
Community Streaming Expert

Re: No local antenna channels when connected to wifi

@descott12 

From Settings/System/About, what are the model numbers and the Software version with build number of your RokuTVs.

When you go to Settings/TV Inputs you should see four options (Scan for Antenna Channels, Manage Channels, Rename, and Remove).  Weird you are missing the Manage Channels menu item.

If you go into the Live TV guide and navigate all the way to the left (highlight the channel number) and press the * button on your Roku Remote, you see see another "Manage Channels" that allows you to edit channel lineup.  Does not include the Hide/Show Streaming Channels option like the Settings menu item does, but do you see any of your Antenna Channels there?  

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
descott12
Channel Surfer

Re: No local antenna channels when connected to wifi

Thanks for the reply. One of the TVs is an Insignia NS-39DR510NA17.

SW 11.5.0 build 4312-12.  This one does not have an antenna attached but going to Settings > TV inputs does not have "Manage channels" as an option. I won't have access to the TV with the antenna for about a week so I don't know the software version but the behavior is the same as far as I can tell.

Also, on this TV, the Live TV guide does not show the grid display with channel numbers and times. It just shows an array of boxes for each show that you can then press * but again, no "Manage channels" option. At one point I saw the guide display with the channel numbers and times of day but I can't get back to that no matter what I try. 

Thanks for your help.

0 Kudos
descott12
Channel Surfer

Re: No local antenna channels when connected to wifi

Alright I just hooked an antenna to another roku TV. It found 33 local channels.

I go to Settings > TV inputs > Live TV and I now have a Manage channels choice. This is not the case on the TV I originally posted about. Anyway, I check the box for "Hide streaming" and when I go to "Manage channels" > "Edit lineup" it will list only the local channels. So far so good.

When I exit out and go the Guide, ONLY the streaming channels show up. No local channels and when I go to Manage channels > Edit lineup again, only the streaming channels are displayed and there are a hundred of  them so I can't just hide each one individually. This is really messed up. Please advise.

0 Kudos
AvsGunnar
Community Streaming Expert

Re: No local antenna channels when connected to wifi

@descott12 

Some of the issue that leads to confusion is that Roku is terming everything "LiveTV" since an update in 10.5 or 11.0.

Lets concentrate on the semi-working RokuTV with the connected Antenna.  Go to Settings/TV Inputs and Rename this Input "Antenna".  (this way can differentiate between Antenna (local channels) and LiveTV (Roku streaming channels, aka linear channels).

After you rename this input, you should now see an Input on your Home Screen named Antenna. (basically a channel icon named Antenna).  Selecting the Antenna Input should only show you your local channels since you selected to hide the streaming channels.  In order to view the EPG Guide (program guide), just press the left arrow on the Roku Remote.  Once inside the EPG Guide, you should be able to navigate over to the channel number, press the * button and select "Manage Channels" and only your Antenna channels should be visible to edit, favorite, etc.

If you want to watch the Roku Streaming Channels, then you would choose the "LiveTV" from the left side Menu of Home Screen.  This should just show you the streaming channels, no antenna/local channels.  Or, you could go to the Roku Channel, then select LiveTV.

See if doing the above helps straighten out your issue.  Posting some screenshots may be helpful as well if you are still running into issues. (use the little camera icon in the message box formatting options).

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
descott12
Channel Surfer

Re: No local antenna channels when connected to wifi

Well renaming did the trick! So simple. Thank you very much. Roku really needs to make this more clear! Much appreciated. I wish I could buy you a cocktail!

bswe2023
Newbie

Re: No local antenna channels when connected to wifi

Go to your Home screen, then Settings, select TV inputs, then find your Antenna TV tile, select Manage channels, and check the box to hide streaming channels.

You should be able to see Antenna channels again.

0 Kudos