brvaland
Reel Rookie

Audio is always PCM instead Dolby

I have bought Roku Streambar recently and connected it to LG OLED C1 using HDMI (arc). 

When I play any movie or content from Netflix, Roku Channel etc the audio on my TV shows it is playing in PCM not Dolby digital.

I understand Roku Streambar does support Dolby Digital but not sure how to enable it.

Please advise ?

Labels (1)
0 Kudos
2 REPLIES 2
RokuArjiemar
Community Moderator
Community Moderator

Re: Audio is always PCM instead Dolby

Hi there @brvaland,

A warm welcome to the Roku Community!

Enabling CEC and ARC is different for every TV brand. Some have separate settings for each, while others combine the features into one setting that turns ARC and CEC on or off at the same time. When looking through your TV's menus for these features, understand that manufacturers may not refer to them by name, but rather as part of a branded trade name. In general, you can often look in a "settings" menu for CEC-related settings, sometimes in a "system" or "advanced" submenu. ARC-related settings may be located in the same place, or they may appear separately in an "audio" or "sound" menu.

  • LG (SIMPLINK)
    Note: SIMPLINK must be enabled using the CEC steps before you can enable ARC
    CEC steps:
    1.Hold Settings on your LG remote for 5 seconds to open the Settings menu
    2.Select All Settings from the bottom right corner of your display
    3.Select General from the left menu
    4.Select SIMPLINK (HDMI-CEC)
    5.Set SIMPLINK (HDMI-CEC) to On, and confirm
  • ARC steps:
    1.Perform LG CEC steps 1 and 2
    2.Select Sound from the left menu
    3.Select Sound Out
    4.Select Audio Out (Optical/HDMI ARC)
    5.Set Digital Sound Out to Auto

If you need additional help, use this link: Why is 4K Dolby Vision not working on my Roku streaming player?

Please feel free to let us know if you need any additional assistance!

Regards,

Arjiemar

Arjiemar
Roku Community Moderator
0 Kudos
brvaland
Reel Rookie

Re: Audio is always PCM instead Dolby

Hi Arjiemar,

I tried to follow below instructions but still it shows PCM.

The LG OLED TV Menu is slightly different to below but managed to find the similar options. Here is what I followed.

LG (SimLink)

  1. Setting button
  2. All settings
  3. General
  4. Devices
  5. HDMI Settings
  6. SIMLINK (HDMI-CEC) set to on

The sound out is set to HDMI (Arc) Device.

I have also set the following set 1-2 and sound > advanced setting 

  • DTV Audio Setting set to Auto
  • HDMI Input audio format - Bitstream
  • Digital Sound Output set to Pass Through. Also tried to change to Auto but did not make any difference.

Please let me know if there are any changes that I may need to do on Roku Streambar.

Regards

Bhavesh

 

0 Kudos