Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Rockie7941
Reel Rookie

Connecting an indoor HDTV antenna to my Onn Roku Smart TV

I connected an indoor HDTV antenna to my TV. I went to settings and Live TV and scanned the channels. It showed 37 channels were available. I went through all the prompts and then clicked on done and the guide came up showing the channels that were loaded.

I went to the guide to see how it looked and where I would see these channels each time I logged into Live TV and the channels were no where to be found. 

I repeated the steps again, again the channels loaded and it showed them, but when I went to change to another channel, they are gone again.

Any idea what is going on?

I even went to setting and checked the streaming channel box to hide the channels and they were all still there.

I have the USB plugged into the USB port and the coaxial cable into the ANT IN. Does this USB need to be plugged in? Could this be my problem?

I am at a loss and really would like to use this antenna as it is picking up all the stations that I have been looking for.

Thanks in advance for any help you can provide.

0 Kudos
7 REPLIES 7
RokuKarla
Retired Moderator

Re: Connecting an indoor HDTV antenna to my Onn Roku Smart TV

Hello @Rockie7941

Thanks for posting in the Roku Community!

Please ensure the system is updated to its latest version. I suggest you follow the troubleshooting steps mentioned below:

1. Restart the system by navigating to Settings->System->Power->System restart
2. Update the system by navigating to Settings->System->System update->Check now
3. Select Settings followed by System
4. Select Zipcode and enter your zip code
5. After you enter your zip code, you need to set up the Live TV input again and let your Roku TV re-scan the "over-the-air" channels.
6. Navigate to Home, and select Live TV. If Live TV is missing, you can add it by going to Settings > TV inputs > Live TV > Set up input
7. Follow the instructions on the TV screen to complete the setup.

For additional information on setting up the Live TV input, please refer to this link: How do I set up the Live TV input on my Roku TV 

Hope you'll find this information useful. Let us know in case you've still got any questions.


Regards,
Karla

0 Kudos

Re: Connecting an indoor HDTV antenna to my Onn Roku Smart TV

I have this same issue on my 75 inch ONN TV. This is not a user issue.Its not a how to scan channels issue. I have tried everything. there is no update. if you go to settings/tv inputs/ live tv/ manage channels/ manage all channels/ edit channel lineup... they are there. once you highlight one, it will show on the screen, then the live menu will see them.

once you go to a non antenna channel, they all disappear from the lineup. GONE. only way to see them again is to repeat the above steps. I even have them marked as favorites. They will not show up on my favorites list in the live lineup. why isnt there an OTA tab like favorites, sports, movies, news, etc.? I know when i initally set up the antenna, they did show in the list. I got the TV back in January of 2023. I dont know if there has been an update since, but im guessing that there was, because something changed.

0 Kudos

Re: Connecting an indoor HDTV antenna to my Onn Roku Smart TV

 well **bleep**..... i just did a second restart of the tv and now they are showing. I dont know why the first one didnt get them to show. Just keep restarting the tv til they show up. lol

0 Kudos
Rockie7941
Reel Rookie

Re: Connecting an indoor HDTV antenna to my Onn Roku Smart TV

Thanks for sharing this information. I got so frustrated that I returned the antenna to the store.

I am still stick paying $$$$$ for Hulu.  Might give it another try. 

Glad you got it to work.

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Connecting an indoor HDTV antenna to my Onn Roku Smart TV

@mrtimbo5150 and @Rockie7941 

Just verifying that you are actually selecting the LiveTV "Input" from the Home Screen. (the tile icon).

If you select LiveTV from the left side Menu, that will only show Roku Channel LiveTV streaming channels. (not OTA/Antenna channels).

I just rename the LiveTV Input (again, the tile icon) to "Antenna" from Settings/TV Inputs/Rename in order to keep them seperate/distinct.  Then you can also Hide/Show the Streaming Channels as well from this Input from Settings/TV Inputs/Manage Channels/Hide Streaming Channels if you wish.

If you Hide the Streaming Channels from the Antenna Input, then you can still watch them via the LiveTV from left side Menu "LiveTV" or accessing them through the Roku Channel channel/app LiveTV section.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
catatop
Newbie

Connecting an indoor HDTV antenna to my Onn Roku Smart TV

I've tried all the above mentioned steps, but I think the problem is my antenna connects to the cable input and the USB, not HDMI. The USB option does not show on the system options. I've added it as "on" vs. "prompt". Only the HDMI inputs show. I'm not getting any local major networks other than the news. How do I get the USB connection to be "read" by the TV to access local channels? 

0 Kudos
Strega2
Roku Guru

Re: Connecting an indoor HDTV antenna to my Onn Roku Smart TV

I’ve never seen an antenna that used HDMI, and I’ve only seen USB used for powering an amplifier, so I think your antenna sounds completely normal.  (ie: the signal connection is the coax cable/f connector connection.)

Banned but back. Because why not?
0 Kudos